Commit f928c9da authored by André Anjos's avatar André Anjos 💬

Use git; Fix menpo requirements; Don't set fn

parent b0e7e500
Pipeline #6867 passed with stage
in 5 minutes and 17 seconds
......@@ -5,9 +5,8 @@ package:
version: {{ version }}
source:
fn: cyvlfeat-{{ version }}.zip
url: https://pypi.python.org/packages/bb/f7/7243e001f6a524cef8ddd32e45a5c60984c2cdb39d267bfe11b03701b3d8/cyvlfeat-{{ version }}.zip
md5: 3c629cafe97ff55b698241197eefd7c3
git_rev: v{{ version }}
git_url: https://github.com/menpo/cyvlfeat.git
build:
number: 0
......
{% set version = "0.7.3" %}
package:
name: ipdb
version: "0.10.2"
version: {{ version }}
source:
fn: ipdb-0.10.2.tar.gz
url: https://pypi.python.org/packages/e1/fa/446cc6443c0dd5bcce55af12b73e1a561b330913a3792d4037f4aa654ed2/ipdb-0.10.2.tar.gz
url: https://pypi.io/packages/source/i/ipdb/ipdb-{{ version }}.tar.gz
md5: 75aad4924214a8526e38aefd4d3099b1
build:
......
......@@ -5,9 +5,8 @@ package:
version: {{ version }}
source:
fn: menpo-{{ version }}.tar.gz
url: https://pypi.python.org/packages/8a/2a/3c8fbe0618267ebd5ae44e452455d3c7a9b554f07e7209a9d41dca359021/menpo-{{ version }}.tar.gz
md5: 0e720b11eda3f9df06965a1a3b6fb4ec
git_rev: v{{ version }}
git_url: https://github.com/menpo/menpo.git
build:
number: 0
......@@ -38,7 +37,7 @@ requirements:
- cyvlfeat >=0.4.3,<0.5
# Visualization
- matplotlib >=1.4
- matplotlib >=1.4,<2.0
test:
requires:
......
......@@ -5,9 +5,8 @@ package:
version: {{ version }}
source:
fn: mne-{{ version }}.tar.gz
url: https://pypi.python.org/packages/2f/1f/f7db5c21d8815da1448bf947849b8b501e26d1a03716b27e60073c5fc187/mne-{{ version }}.tar.gz
md5: 51cc1e955e96e7fa8c3f900895fc471a
git_url: https://github.com/mne-tools/mne-python.git
git_rev: v{{ version }}
build:
number: 0
......@@ -28,9 +27,20 @@ requirements:
- pandas
test:
requires:
- nose
source_files:
- mne/io/brainvision/tests/data/*
- mne/io/bti/tests/data/*
- mne/io/edf/tests/data/*
- mne/io/egi/tests/data/*
- mne/io/kit/tests/data/*
- mne/io/nicolet/tests/data/*
- mne/io/tests/data/*
- mne/preprocessing/tests/data/*
imports:
- mne
- mne.beamformer
......@@ -104,6 +114,9 @@ test:
- mne.viz
- mne.viz.tests
commands:
- nosetests -sv mne
about:
home: https://github.com/mne-tools/mne-python/
summary: Magnetoencephalography (MEG) and Electroencephalography (EEG) in Python
......
......@@ -5,8 +5,7 @@ package:
version: 1.0
source:
fn: pathlib-{{ version }}.tar.gz
url: https://pypi.python.org/packages/source/p/pathlib/pathlib-{{ version }}.tar.gz
url: https://pypi.io/packages/source/p/pathlib/pathlib-{{ version }}.tar.gz
md5: a0a834e2ac9e280f9cfc3a06f5ac1ca3
build:
......
{% set version = "0.7.3" %}
package:
name: pkgtools
version: "0.7.3"
version: {{ version }}
source:
fn: pkgtools-0.7.3.tar.gz
url: https://pypi.python.org/packages/1c/4c/2a68aae6f0bc194749c733f64fd7da4d273aa735407c44fee3dd74069852/pkgtools-0.7.3.tar.gz
url: https://pypi.io/packages/source/p/pkgtools/pkgtools-{{ version }}.tar.gz
md5: f23b4aaf2fb4893df8f5225a9edb6a07
build:
......
......@@ -5,8 +5,7 @@ package:
version: {{ version }}
source:
fn: pyEDFlib-{{ version }}.tar.gz
url: https://pypi.python.org/packages/07/0c/2c9b2b94637952691e3cfc6b20752fdf02878eebf50f53fdbfca4d96727e/pyEDFlib-{{ version }}.tar.gz
url: https://pypi.io/packages/source/p/pyEDFlib/pyEDFlib-{{ version }}.tar.gz
md5: 1a71a66b016a02c721b5ae59c830bd4f
build:
......
......@@ -3,8 +3,7 @@ package:
version: "0.6.5"
source:
fn: schema-0.6.5.tar.gz
url: https://pypi.python.org/packages/2b/4a/b611e3dc7638c416be86c3bf179bbb9a9abb418f82b3fe32a4c5713c8993/schema-0.6.5.tar.gz
url: https://pypi.io/packages/source/s/schema/schema-{{ version }}.tar.gz
md5: 49966546df976a664b8b2be2764aa83a
build:
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment