Commit da2f7645 authored by André Anjos's avatar André Anjos 💬
Browse files

Added docker-py package

parent 7e026df3
Pipeline #19275 failed with stage
in 35 minutes and 4 seconds
package:
name: beat-devel
version: 2018.04.19
version: 2018.04.20
build:
number: 0
......@@ -16,6 +16,9 @@ requirements:
- requests 2.18.4
- simplejson 3.13.2
- pyzmq 17.0.0
- python-graphviz 0.8.2
- jsonschema 2.6.0
- docker-py 3.2.1
run:
- python
run_constrained:
......
{% set version = "3.2.1" %}
package:
name: docker-py
version: {{ version }}
source:
url: https://github.com/docker/docker-py/archive/{{ version }}.tar.gz
sha256: 0cbff988d1520d71e75951a2b58b1b5dabdd7a72c0607fd7c3d2c5d6d0663beb
build:
number: 0
script: python setup.py install --single-version-externally-managed --record=record.txt
requirements:
build:
- python
- setuptools
run:
- python
- requests >=2.14.2
- six >=1.10.0
- ssl_match_hostname >=3.5 # [py<35]
- ipaddress >=1.0.18 # [py<33]
- appdirs >=1.4.3
- asn1crypto >=0.22.0
- cffi >=1.10.0
- cryptography >=1.9
- docker-pycreds >=0.2.1
- enum34 >=1.1.6 # [py<34]
- idna >=2.5
- packaging >=16.8
- pycparser >=2.17
- pyopenssl >=17.0.0
- pyparsing >=2.2.0
- websocket-client >=0.40.0
test:
imports:
- docker
- docker.api
- docker.auth
- docker.tls
- docker.utils
- docker.utils.ports
- docker.transport.unixconn
about:
home: https://github.com/docker/docker-py/
license: Apache 2.0
summary: 'Python client for Docker'
extra:
recipe-maintainers:
- anjos
......@@ -36,6 +36,7 @@ PACKAGES+=('conda/schema')
PACKAGES+=('conda/madmom')
PACKAGES+=('conda/docker-pycreds')
PACKAGES+=('conda/websocket-client')
PACKAGES+=('conda/docker-py')
PACKAGES+=('conda/bob-devel')
PACKAGES+=('conda/beat-devel')
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment