Commit 5e7f1ce6 authored by André Anjos's avatar André Anjos 💬
Browse files

[beat-devel] Use docker-py and friends, black from defaults (closes #74, closes #75)

parent cb58f359
Pipeline #32359 passed with stage
in 70 minutes and 27 seconds
......@@ -2,7 +2,7 @@
{% set nopin = ['ca-certificates', 'certifi', 'openssl', 'libstdcxx-ng', 'libgcc-ng', 'libcxx', 'libcxxabi'] %}
package:
name: beat-devel
version: 2019.08.04
version: 2019.08.07
build:
# the build number must be zero all the time.
......@@ -16,7 +16,7 @@ requirements:
host:
- python {{ python }}
- bob-devel 2019.08.04
- docker-py 3.6.0
- docker-py 4.0.2
- flask 1.0.2
- flask-cors 3.0.7
- flask-restful 0.3.6
......
{% set name = "black" %}
{% set version = "18.9b0" %}
{% set sha256 = "e030a9a28f542debc08acceb273f228ac422798e5215ba2a791a6ddeaaca22a5" %}
package:
name: {{ name|lower }}
version: {{ version }}
source:
fn: {{ name }}-{{ version }}.tar.gz
url: https://pypi.io/packages/source/{{ name[0] }}/{{ name }}/{{ name }}-{{ version }}.tar.gz
sha256: {{ sha256 }}
build:
number: 0
script: "{{ PYTHON }} -m pip install --no-deps --ignore-installed --no-cache-dir ."
entry_points:
- black = black:main
requirements:
host:
- python
- pip
run:
- python
- click >=6.5
- attrs >=18.1.0
- appdirs
- toml >=0.9.4
test:
commands:
- black --help
about:
home: https://github.com/ambv/black
license: MIT
license_family: MIT
license_file: LICENSE
summary: 'The Uncompromising Code Formatter'
description: |
Black is the uncompromising Python code formatter. By using it, you agree
to cease control over minutiae of hand-formatting. In return, Black gives
you speed, determinism, and freedom from pycodestyle nagging about
formatting. You will save time and mental energy for more important matters.
doc_url: https://github.com/ambv/black
dev_url: https://github.com/ambv/black
extra:
recipe-maintainers:
- sgaist
{% set version = "3.6.0" %}
package:
name: docker-py
version: {{ version }}
source:
url: https://github.com/docker/docker-py/archive/{{ version }}.tar.gz
sha256: f755d044eb27c63486fe7dcfef7f1f5500456e23f3142a5b237a0ab504267a22
build:
number: 0
script: python -m pip install --no-deps --ignore-installed .
requirements:
build:
- python
- setuptools
- pip
run:
- python
- requests >=2.14.2
- six >=1.10.0
- websocket-client >=0.32.0
- docker-pycreds >=0.3.0
- ssl_match_hostname >=3.5 # [py<35]
- ipaddress >=1.0.18 # [py<33]
- pypiwin32 >=219 # [win32]
- appdirs >=1.4.3
- asn1crypto >=0.22.0
- cffi >=1.10.0
- cryptography >=1.9
- docker-pycreds >=0.2.1
- enum34 >=1.1.6 # [py<34]
- idna >=2.5
- packaging >=16.8
- pycparser >=2.17
- pyopenssl >=17.0.0
- pyparsing >=2.2.0
- websocket-client >=0.40.0
test:
imports:
- docker
- docker.api
- docker.auth
- docker.tls
- docker.utils
- docker.utils.ports
- docker.transport.unixconn
about:
home: https://github.com/docker/docker-py/
license: Apache 2.0
license_file: LICENSE
summary: 'Python client for Docker.'
extra:
recipe-maintainers:
- anjos
{% set version = "0.3.0" %}
package:
name: docker-pycreds
version: {{ version }}
source:
fn: docker-pycreds-{{ version }}.tar.gz
url: https://github.com/shin-/dockerpy-creds/archive/{{ version }}.tar.gz
sha256: 3660a5e9fc7c2816ab967e4bdb4802f211e35011357ae612a601d6944721e153
build:
number: 0
script: python -m pip install --no-deps --ignore-installed .
requirements:
build:
- pip
- python
- setuptools
- six >=1.4.0
run:
- python
- six >=1.4.0
test: #this requires docker support for testing...
imports:
- dockerpycreds
about:
home: https://github.com/shin-/docker-pycreds/
license: Apache-2.0
summary: 'Python bindings for the docker credentials store API'
license_file: LICENSE
license_family: Apache
extra:
recipe-maintainers:
- anjos
{% set name = "websocket-client" %}
{% set snakename = "websocket_client" %}
{% set bundle = "tar.gz" %}
{% set version = "0.54.0" %}
{% set hash_type = "sha256" %}
{% set hash_val = "e51562c91ddb8148e791f0155fdb01325d99bb52c4cdbb291aee7a3563fd0849" %}
package:
name: {{ name }}
version: {{ version }}
source:
fn: {{ name }}-{{ version }}.{{ bundle }}
url: https://pypi.io/packages/source/{{ name[0] }}/{{ snakename }}/{{ snakename }}-{{ version }}.{{ bundle }}
{{ hash_type }}: {{ hash_val }}
build:
number: 0
script: python -m pip install --no-deps --ignore-installed .
requirements:
build:
- pip
- python
- setuptools
run:
- python
- six
test:
requires:
- nose
- coverage
imports:
- websocket
- websocket.tests
commands:
- TEST_WITH_INTERNET=1 nosetests -v --with-coverage --cover-package=websocket websocket --exclude=".*testKeepRunning.*"
- conda inspect linkages -p $PREFIX {{ name }} # [not win]
- conda inspect objects -p $PREFIX {{ name }} # [osx]
about:
home: https://github.com/liris/websocket-client
license: LGPL 2.1
license_family: LGPL
summary: 'WebSocket client for python. hybi13 is supported.'
extra:
recipe-maintainers:
- anjos
......@@ -11,15 +11,11 @@ conda/pyedflib
conda/schema
conda/mido
conda/madmom
conda/docker-pycreds
conda/websocket-client
conda/docker-py
conda/oset
conda/sphinxcontrib-programoutput
conda/sphinxcontrib-httpdomain
conda/aniso8601
conda/flask-restful
conda/black
conda/aspy.yaml
conda/cfgv
conda/identify
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment