Commit e9a9f435 authored by Tiago de Freitas Pereira's avatar Tiago de Freitas Pereira
Browse files

[conda] Fixes

parent 9cab01a4
Pipeline #58235 failed with stage
in 1 minute and 38 seconds
include LICENSE README.rst buildout.cfg develop.cfg requirements.txt version.txt
recursive-include doc conf.py *.rst
recursive-include bob/learn/linear *.cpp *.h
recursive-include bob/learn/linear/data *.*
recursive-include doc *.py *.rst
# see https://docs.python.org/3/library/pkgutil.html
from pkgutil import extend_path
__path__ = extend_path(__path__, __name__)
......@@ -41,7 +41,7 @@ test:
imports:
- {{ name }}
commands:
- pytest --verbose --cov {{ name }} --cov-report term-missing --cov-report html:{{ project_dir }}/sphinx/coverage --cov-report xml:{{ project_dir }}
- pytest --capture=no --verbose --cov {{ name }} --cov-config {{ project_dir }}/pyproject.toml --cov-report term-missing --cov-report html:{{ project_dir }}/sphinx/coverage --cov-report xml:{{ project_dir }}/coverage.xml --pyargs {{ name }}
- sphinx-build -aEW {{ project_dir }}/doc {{ project_dir }}/sphinx
- sphinx-build -aEb doctest {{ project_dir }}/doc sphinx
- conda inspect linkages -p $PREFIX {{ name }} # [not win]
......
......@@ -8,7 +8,7 @@ from setuptools import setup, find_packages, dist
from bob.extension.utils import load_requirements
build_requires = load_requirements()
install_requires = load_requirements()
# Define package version
version = open("version.txt").read().rstrip()
......@@ -25,9 +25,15 @@ setup(
long_description=open("README.rst").read(),
include_package_data=True,
zip_safe=False,
setup_requires=build_requires,
install_requires=build_requires,
ext_modules=[],
setup_requires=install_requires,
# This line is required for any distutils based packaging.
packages=find_packages(),
# This line defines which packages should be installed when you "install"
# this package. All packages that are mentioned here, but are not installed
# on the current system will be installed locally and only visible to the
# scripts of this package. Don't worry - You won't need administrative
# privileges when using buildout.
install_requires=install_requires,
entry_points={"console_scripts": [],},
classifiers=[
"Framework :: Bob",
......@@ -40,3 +46,4 @@ setup(
"Topic :: Software Development :: Libraries :: Python Modules",
],
)
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment