Commit 6e8d4106 authored by Amir MOHAMMADI's avatar Amir MOHAMMADI

[conda_build_config] streamline pinned versions

parent 8920b85d
Pipeline #45829 passed with stage
in 6 minutes and 14 seconds
......@@ -95,46 +95,16 @@ make:
pkg_config:
- 0.29.2
# The dependencies that we link against (host requirements).
# Ideally we want to build against the oldest possible version of packages when
# we are linking against them. It is best to keep this in sync with:
# https://github.com/AnacondaRecipes/aggregate/blob/master/conda_build_config.yaml
# The level of pins (x, x.x, or x.x.x) depends on the run_exports of the package
# The host requirements. Ideally we want to build against the oldest possible version of
# packages so packages can be installed with a wide range of versions. But the versions
# here should also be compatible with the pinned versions in bob-devel. For most
# dependencies, you want to put the exact version of bob-devel in here as well. It is
# best to keep this in sync with:
# https://github.com/AnacondaRecipes/aggregate/blob/master/conda_build_config.yaml The
# names here should not contain dots or dashes. You should replace dots and dashes with
# underlines.
boost:
- 1.73
ffmpeg:
- 4.2
freetype:
- 2.10
giflib:
- 5
hdf5:
- 1.10.6
jpeg:
- 9
libblitz:
- 1.0.1
libpng:
- 1.6
libsvm:
- 3.24
libtiff:
- 4.1
mkl:
- 2019
numpy:
- 1.16
pybind11:
- 2.4
sox:
- 14.4.2
vlfeat:
- 0.9.21
# The dependencies that are needed for runtime only (run requirements). These versions
# **should** match the versions inside bob-devel recipe. In fact, you can copy the
# bob-devel pins here and remove the ones that are already in the "build" requirements,
# above (like numpy, boost). You should also replace dots and dashes with underlines.
- 1.73.0
click:
- 7.1.2
click_plugins:
......@@ -153,18 +123,40 @@ docker_py:
- 4.3.1
docopt:
- 0.6.2
ffmpeg:
- 4.2.2
freetype:
- 2.10.4
giflib:
- 5.2.1
h5py:
- 2.10.0
hdf5:
- 1.10.6
jinja2:
- 2.11.2
jpeg:
- 9b
jsonschema:
- 3.2.0
libblitz:
- 1.0.1
libpng:
- 1.6.37
libsvm:
- 3.24
libtiff:
- 4.1.0
matplotlib:
- 3.3.2
mkl:
- 2019.4
ncurses:
- 6.2
nose:
- 1.3.7
numpy: # we build against numpy 1.16 but test against newer versions.
- 1.16
opencv:
- 4.5.0
pandas:
......@@ -173,6 +165,8 @@ pillow:
- 8.0.1
psycopg2:
- 2.8.5
pybind11:
- 2.5.0
pyopengl:
- 3.1.1
pyqtgraph:
......@@ -208,7 +202,9 @@ setuptools:
simplejson:
- 3.17.2
six:
- 1
- 1.15.0
sox:
- 14.4.2
sphinx:
- 3.2.1
sphinx_rtd_theme:
......@@ -229,6 +225,8 @@ torchvision:
- 0.8.1
tqdm:
- 4.50.2
vlfeat:
- 0.9.21
xarray:
- 0.16.1
zc_buildout:
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment