Commit 1f269f77 authored by Hakan GIRGIN's avatar Hakan GIRGIN
Browse files

Python3 compatibility added

parent 47665526
from setuptools import setup, find_packages
import sys
# Setup:
setup(name='pbdlib',
version='0.1',
description='Programming by Demonstration module for Python',
url='',
author='Emmanuel Pignat',
author_email='emmanuel.pignat@idiap.ch',
license='MIT',
packages=find_packages(),
install_requires = ['numpy','scipy','matplotlib', 'sklearn', 'dtw', 'jupyter', 'enum', 'termcolor'],
zip_safe=False)
\ No newline at end of file
if sys.version_info[0]==2:
# Setup for Python2
setup(name='pbdlib',
version='0.1',
description='Programming by Demonstration module for Python',
url='',
author='Emmanuel Pignat',
author_email='emmanuel.pignat@idiap.ch',
license='MIT',
packages=find_packages(),
install_requires = ['numpy','scipy','matplotlib', 'sklearn', 'dtw', 'jupyter', 'enum', 'termcolor'],
zip_safe=False)
else:
# Setup for Python3
setup(name='pbdlib',
version='0.1',
description='Programming by Demonstration module for Python',
url='',
author='Emmanuel Pignat',
author_email='emmanuel.pignat@idiap.ch',
license='MIT',
packages=find_packages(),
install_requires = ['numpy','scipy','matplotlib', 'sklearn', 'dtw', 'jupyter', 'termcolor'],
zip_safe=False)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment