Commit e78fdc6e authored by André Anjos's avatar André Anjos 💬 Committed by Amir MOHAMMADI
Browse files

[sphinxcontrib-programoutput] Move dependency up so it can be used in Bob

parent 073c45d9
......@@ -2,7 +2,7 @@
{% set nopin = ['ca-certificates', 'certifi', 'openssl', 'libstdcxx-ng', 'libgcc-ng', 'libcxx', 'libcxxabi'] %}
package:
name: beat-devel
version: 2020.01.09
version: 2020.03.29
build:
# the build number must be zero all the time.
......@@ -14,17 +14,15 @@ build:
requirements:
host:
- bob-devel 2020.01.09
- bob-devel 2020.03.29
- python {{ python }}
- docker-py 4.0.2
- jsonschema 3.0.2
- python-graphviz 0.8.4
- pyzmq 17.1.2
- docker-py 4.2.0
- jsonschema 3.2.0
- python-graphviz 0.13.2
- pyzmq 18.1.1
- simplejson 3.17.0
- sphinxcontrib-programoutput 0.15
- sphinxcontrib-httpdomain 1.7.0
- psycopg2 2.7.6.1
- ncurses 6.1
- ncurses 6.2
run:
- python
run_constrained:
......
......@@ -4,7 +4,7 @@ package:
name: bob-devel
# please update the version of beat-devel and update bob-devel's version
# there as well in the same merge request.
version: 2020.01.09
version: 2020.03.29
build:
# the build number must be zero all the time.
......@@ -25,10 +25,10 @@ requirements:
# reproducibility.
- boost 1.67.0
- caffe 1.0 # [linux]
- click 7.0
- click 7.1.1
- click-plugins 1.1.1
- cmake 3.14.0
- coverage 4.5.3
- coverage 5.0
- cyvlfeat 0.5.1
- docopt 0.6.2
# to make sure we get ffmpeg from our own channel which has more codecs
......@@ -38,7 +38,7 @@ requirements:
- giflib 5.1.4
- h5py 2.8.0
- hdf5 1.10.2
- jinja2 2.10.1
- jinja2 2.11.1
- jpeg 9b
- kaldi 1!5.5.164 # [linux]
- libblitz 1.0.1
......@@ -46,44 +46,46 @@ requirements:
- libogg 1.3.2
- libpng 1.6.37
- libsvm 3.24
- libtiff 4.0.10
- matplotlib 3.1.0
- libtiff 4.1.0
- matplotlib 3.1.3
- menpo 0.9.2
- menpofit 0.6.1
- mkl 2019.4
- mne 0.18.1
- mr.developer 2.0.0
- nose 1.3.7
- numpy 1.16.4
- numpy 1.18.1
- opencv 3.4.2
- pillow 6.1.0
- pillow 6.2.1
- pkg-config 0.29.2
- pyedflib 0.1.14
- cudatoolkit 9.0 # [linux]
- pandas 0.25.1
- pandas 1.0.3
- pytorch 1.0.1 # [linux]
- pyyaml 5.1.1
- requests 2.22.0
- pyyaml 5.3.1
- requests 2.23.0
- schema 0.7.1
- scikit-image 0.15.0
- scikit-learn 0.21.2
- scipy 1.2.1
- setuptools 41.0.1
- six 1.12.0
- scikit-image 0.16.2
- scikit-learn 0.22.1
- scipy 1.4.1
- setuptools 46.1.1
- six 1.14.0
- sox 14.4.2
- sphinx 2.1.2
- sphinx 2.4.4
- sphinx_rtd_theme 0.4.3
- sqlalchemy 1.3.5
- sphinxcontrib-programoutput 0.15
- sqlalchemy 1.3.15
- tabulate 0.8.3
- tensorflow 1.14.0
- tensorflow 1.15.0
- torchvision 0.2.1 # [linux]
- tqdm 4.32.1
- tqdm 4.43.0
- vlfeat 0.9.21
- zc.buildout 2.13.2
- zc.recipe.egg 2.0.7
# beat-devel direct dependencies that leak to bob-devel as indirect
# dependencies:
- termcolor 1.1.0
- psycopg2 2.8.4
# semi-supported dependencies (drop them if they conflict):
- dlib 19.7
run:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment