Commit e1dbe3d0 authored by André Anjos's avatar André Anjos 💬
Browse files

Merge branch 'remove_oset' into 'master'

Remove oset, add dependencies for bob.ip.binseg

See merge request bob/bob.conda!431
parents f6f961b5 cfbe2a82
Pipeline #33084 passed with stage
in 50 minutes and 23 seconds
...@@ -2,7 +2,7 @@ ...@@ -2,7 +2,7 @@
{% set nopin = ['ca-certificates', 'certifi', 'openssl', 'libstdcxx-ng', 'libgcc-ng', 'libcxx', 'libcxxabi'] %} {% set nopin = ['ca-certificates', 'certifi', 'openssl', 'libstdcxx-ng', 'libgcc-ng', 'libcxx', 'libcxxabi'] %}
package: package:
name: beat-devel name: beat-devel
version: 2019.08.28 version: 2019.09.05
build: build:
# the build number must be zero all the time. # the build number must be zero all the time.
...@@ -15,14 +15,13 @@ build: ...@@ -15,14 +15,13 @@ build:
requirements: requirements:
host: host:
- python {{ python }} - python {{ python }}
- bob-devel 2019.08.28 - bob-devel 2019.09.05
- docker-py 4.0.2 - docker-py 4.0.2
- flask 1.0.2 - flask 1.0.2
- flask-cors 3.0.7 - flask-cors 3.0.7
- flask-restful 0.3.6 - flask-restful 0.3.6
- jsonschema 3.0.1 - jsonschema 3.0.1
- nodejs 8.9.3 - nodejs 8.9.3
- oset 0.1.3
- python-graphviz 0.8.4 - python-graphviz 0.8.4
- pyzmq 17.1.2 - pyzmq 17.1.2
- simplejson 3.16.0 - simplejson 3.16.0
......
...@@ -4,7 +4,7 @@ package: ...@@ -4,7 +4,7 @@ package:
name: bob-devel name: bob-devel
# please update the version of beat-devel and update bob-devel's version # please update the version of beat-devel and update bob-devel's version
# there as well in the same merge request. # there as well in the same merge request.
version: 2019.08.28 version: 2019.09.05
build: build:
# the build number must be zero all the time. # the build number must be zero all the time.
...@@ -63,6 +63,7 @@ requirements: ...@@ -63,6 +63,7 @@ requirements:
- pkg-config 0.29.2 - pkg-config 0.29.2
- pyedflib 0.1.14 - pyedflib 0.1.14
- cudatoolkit 9.0 # [linux] - cudatoolkit 9.0 # [linux]
- pandas 0.25.1
- pytorch 1.0.1 # [linux] - pytorch 1.0.1 # [linux]
- pyyaml 5.1.1 - pyyaml 5.1.1
- requests 2.22.0 - requests 2.22.0
...@@ -79,6 +80,7 @@ requirements: ...@@ -79,6 +80,7 @@ requirements:
- tabulate 0.8.3 - tabulate 0.8.3
- tensorflow 1.14.0 - tensorflow 1.14.0
- torchvision 0.2.1 # [linux] - torchvision 0.2.1 # [linux]
- tqdm 4.32.1
- vlfeat 0.9.21 - vlfeat 0.9.21
- zc.buildout 2.13.2 - zc.buildout 2.13.2
- zc.recipe.egg 2.0.7 - zc.recipe.egg 2.0.7
......
{% set name = "oset" %}
{% set version = "0.1.3" %}
package:
name: {{ name }}
version: {{ version }}
source:
fn: {{ name }}-{{ version }}.tar.gz
url: https://pypi.org/packages/source/o/{{ name }}/{{ name }}-{{ version }}.tar.gz
sha256: 4c1fd7dec96eeff9d3260995a8e37f9f415d0bdb79975f57824e68716ac8f904
build:
number: 0
script: python setup.py install --single-version-externally-managed --record=record.txt
requirements:
build:
- python
- setuptools
run:
- python
test:
requires:
- nose
- coverage
imports:
- {{ name }}
commands:
#- nosetests {{ name }} -v --with-coverage --cover-package={{ name }}
about:
home: https://pypi.org/project/oset/
license: Python License (Python-2.0)
summary: Set that remembers original insertion order
extra:
recipe-maintainers:
- anjos
...@@ -9,7 +9,6 @@ conda/zc.recipe.egg ...@@ -9,7 +9,6 @@ conda/zc.recipe.egg
conda/mr.developer conda/mr.developer
conda/pyedflib conda/pyedflib
conda/schema conda/schema
conda/oset
conda/sphinxcontrib-programoutput conda/sphinxcontrib-programoutput
conda/sphinxcontrib-httpdomain conda/sphinxcontrib-httpdomain
conda/aniso8601 conda/aniso8601
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment