Commit a7de7e3e authored by Amir MOHAMMADI's avatar Amir MOHAMMADI

more conda build 3 pinnings

parent 4cb9a847
......@@ -18,15 +18,15 @@ requirements:
- libgcc {{ libgcc }} # [linux]
- python
- setuptools
- numpy x.x
- numpy {{ numpy }}
- cython >0.23
- vlfeat 0.9.*
- vlfeat {{ vlfeat }}
- msinttypes r26 # [win]
run:
- python
- vlfeat 0.9.*
- numpy x.x
- vlfeat
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -24,22 +24,22 @@ requirements:
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
- cmake
- mkl # [not win]
- numpy x.x
- mkl {{ mkl }} # [not win]
- numpy {{ numpy }}
- boost {{ boost }}
- jpeg {{ jpeg }} # [not win]
- libpng {{ libpng }}
- sqlite 3.13.* # [not win]
- sqlite {{ sqlite }} # [not win]
run:
- python
- libgcc # [linux]
- mkl # [not win]
- numpy x.x
- boost 1.61.*
- jpeg 9b # [not win]
- libpng >=1.6.27,<1.7
- sqlite 3.13.* # [not win]
- mkl # [not win]
- numpy {{ numpy }}
- boost
- jpeg # [not win]
- libpng
- {{ pin_compatible('sqlite') }} # [not win]
test:
files:
......
......@@ -15,13 +15,13 @@ build:
requirements:
build:
- toolchain {{ toolchain }}
- hdf5 1.8.17|1.8.17.*
- hdf5 {{ hdf5 }}
- zlib 1.2.8
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- hdf5 1.8.17|1.8.17.*
- hdf5
- zlib >=1.2.8,<1.3
- libgcc # [linux]
......
......@@ -22,13 +22,14 @@ requirements:
- libgcc {{ libgcc }} # [linux]
- python
- setuptools
- numpy x.x
- numpy {{ numpy }}
- cython >=0.23
- ffmpeg {{ ffmpeg }}
run:
- python
- pathlib 1.0 # [py2k]
- numpy x.x
- numpy {{ numpy }}
- libgcc # [linux]
# Scientific Python Stack
......
......@@ -16,11 +16,11 @@ requirements:
build:
- python
- setuptools
- numpy x.x
- numpy {{ numpy }}
run:
- python
- numpy x.x
- numpy {{ numpy }}
- scipy
- matplotlib
- scikit-learn
......
......@@ -28,8 +28,8 @@ requirements:
# For applying patches
- git # [win]
- cmake
- numpy x.x
- hdf5 1.8.17|1.8.17.* # [unix]
- numpy {{ numpy }}
- hdf5 {{ hdf5 }} # [unix]
- eigen 3.*
- zlib 1.2.8
- jpeg {{ jpeg }}
......@@ -41,11 +41,11 @@ requirements:
run:
- python
- numpy x.x
- hdf5 1.8.17|1.8.17.* # [unix]
- numpy {{ numpy }}
- hdf5 # [unix]
- zlib >=1.2.8,<1.3
- libpng >=1.6.27,<1.7
- jpeg 9b
- libpng
- jpeg
- libtiff >=4.0.6,<5
- libgcc # [linux]
......
......@@ -19,12 +19,12 @@ requirements:
- libgcc {{ libgcc }} # [linux]
- python
- setuptools
- numpy x.x
- numpy {{ numpy }}
- cython >=0.23
run:
- python
- numpy x.x
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -24,7 +24,7 @@ requirements:
- libgcc {{ libgcc }} # [linux]
run:
- libpng >=1.6.27,<1.7
- libpng
- zlib >=1.2.8,<1.3
- xz >=5.2.2,<6.0
- libgcc # [linux]
......
......@@ -23,7 +23,7 @@ requirements:
- bob.core
- bob.sp
- libblitz {{ libblitz }}
- numpy x.x
- numpy {{ numpy }}
- scipy
- cmake
- pkg-config
......@@ -36,8 +36,8 @@ requirements:
- bob.blitz
- bob.core
- bob.sp
- libblitz 0.10|0.10.*
- numpy x.x
- libblitz
- numpy {{ numpy }}
- scipy
- libgcc # [linux]
......
......@@ -19,7 +19,7 @@ requirements:
- python
- setuptools
- bob.extension
- numpy x.x
- numpy {{ numpy }}
- pkg-config
- libblitz {{ libblitz }}
- boost {{ boost }}
......@@ -30,9 +30,9 @@ requirements:
run:
- python
- bob.extension
- numpy x.x
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy {{ numpy }}
- libblitz
- boost
- libgcc # [linux]
test:
......
......@@ -23,16 +23,16 @@ requirements:
- bob.blitz
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
- bob.blitz
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -26,8 +26,8 @@ requirements:
- bob.io.matlab
- libblitz {{ libblitz }}
- boost {{ boost }}
- sox 14.4.2
- numpy x.x
- sox {{ sox }}
- numpy {{ numpy }}
- pkg-config
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -40,10 +40,10 @@ requirements:
- bob.core
- bob.io.base
- bob.io.matlab
- libblitz 0.10|0.10.*
- boost 1.61.*
- sox 14.4.2
- numpy x.x
- libblitz
- boost
- sox
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -22,11 +22,11 @@ requirements:
- bob.blitz
- bob.core
- libblitz {{ libblitz }}
- hdf5 1.8.17|1.8.17.*
- hdf5 {{ hdf5 }}
- cmake
- pkg-config
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -35,10 +35,10 @@ requirements:
- bob.extension
- bob.blitz
- bob.core
- libblitz 0.10|0.10.*
- hdf5 1.8.17|1.8.17.*
- boost 1.61.*
- numpy x.x
- libblitz
- hdf5
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -29,7 +29,7 @@ requirements:
- jpeg {{ jpeg }}
- libtiff {{ libtiff }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- cmake
- pkg-config
- gcc {{ gcc }} # [linux]
......@@ -42,13 +42,13 @@ requirements:
- bob.core
- bob.io.base >=2.0.9
- matplotlib
- libblitz 0.10|0.10.*
- giflib >=5.1.4,<6
- libpng >=1.6.27,<1.7
- jpeg 9b
- libblitz
- giflib
- libpng
- jpeg
- libtiff >=4.0.6,<5
- boost 1.61.*
- numpy x.x
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -23,10 +23,10 @@ requirements:
- bob.core
- bob.io.base
- libblitz {{ libblitz }}
- libmatio 1.5.*
- libmatio {{ libmatio }}
- pkg-config
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -36,10 +36,10 @@ requirements:
- bob.blitz
- bob.core
- bob.io.base
- libblitz 0.10|0.10.*
- libmatio 1.5.*
- boost 1.61.*
- numpy x.x
- libblitz
- libmatio
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -26,9 +26,9 @@ requirements:
- bob.core
- bob.io.base
- libblitz {{ libblitz }}
- ffmpeg 2.8.10
- ffmpeg {{ ffmpeg }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- pkg-config
- olefile
- gcc {{ gcc }} # [linux]
......@@ -41,10 +41,10 @@ requirements:
- bob.blitz
- bob.core
- bob.io.base
- libblitz 0.10|0.10.*
- ffmpeg >=2.8.10,<2.9
- boost 1.61.*
- numpy x.x
- libblitz
- ffmpeg
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -26,9 +26,9 @@ requirements:
- bob.io.base
- bob.math
- libblitz {{ libblitz }}
- vlfeat 0.9.20
- vlfeat {{ vlfeat }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- cmake
- pkg-config
- gcc {{ gcc }} # [linux]
......@@ -43,10 +43,10 @@ requirements:
- bob.sp
- bob.io.base
- bob.math
- libblitz 0.10|0.10.*
- vlfeat 0.9.20
- boost 1.61.*
- numpy x.x
- libblitz
- vlfeat
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -26,7 +26,7 @@ requirements:
- cmake
- pkg-config
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -36,9 +36,9 @@ requirements:
- bob.blitz
- bob.core
- bob.io.base
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -21,7 +21,7 @@ requirements:
- bob.extension >2.0.4
- bob.blitz
- libblitz {{ libblitz }}
- numpy x.x
- numpy {{ numpy }}
- pkg-config
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -30,8 +30,8 @@ requirements:
- python
- bob.extension >2.0.4
- bob.blitz
- libblitz 0.10|0.10.*
- numpy x.x
- libblitz
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -33,7 +33,7 @@ requirements:
- bob.io.image
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- pkg-config
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -45,9 +45,9 @@ requirements:
- bob.ip.draw
- bob.ip.color
- bob.io.image
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -29,7 +29,7 @@ requirements:
- matplotlib
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- pkg-config
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -45,9 +45,9 @@ requirements:
- bob.ip.color
- bob.ip.draw
- matplotlib
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -28,7 +28,7 @@ requirements:
- pkg-config
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -40,9 +40,9 @@ requirements:
- bob.core
- bob.io.base
- bob.sp
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -26,7 +26,7 @@ requirements:
- bob.ip.color
- scipy
- libblitz {{ libblitz }}
- numpy x.x
- numpy {{ numpy }}
- pkg-config
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -40,8 +40,8 @@ requirements:
- bob.io.base
- bob.ip.color
- scipy
- libblitz 0.10|0.10.*
- numpy x.x
- libblitz
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -27,7 +27,7 @@ requirements:
- bob.io.video
- bob.ip.color
- libblitz {{ libblitz }}
- numpy x.x
- numpy {{ numpy }}
- pkg-config
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -40,8 +40,8 @@ requirements:
- bob.io.image
- bob.io.video
- bob.ip.color
- libblitz 0.10|0.10.*
- numpy x.x
- libblitz
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -26,7 +26,7 @@ requirements:
- bob.ip.base
- bob.ip.draw
- bob.ip.color
- numpy x.x
- numpy {{ numpy }}
- scipy
- libblitz {{ libblitz }}
- gcc {{ gcc }} # [linux]
......@@ -42,9 +42,9 @@ requirements:
- bob.ip.base
- bob.ip.draw
- bob.ip.color
- numpy x.x
- numpy {{ numpy }}
- scipy
- libblitz 0.10|0.10.*
- libblitz
- libgcc # [linux]
test:
......
......@@ -24,7 +24,7 @@ requirements:
- bob.io.base
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- cmake
- pkg-config
- gcc {{ gcc }} # [linux]
......@@ -36,9 +36,9 @@ requirements:
- bob.blitz
- bob.core
- bob.io.base
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -27,7 +27,7 @@ requirements:
- bob.io.base
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- cmake
- pkg-config
- gcc {{ gcc }} # [linux]
......@@ -40,9 +40,9 @@ requirements:
- bob.blitz
- bob.core
- bob.io.base
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -30,7 +30,7 @@ requirements:
- pkg-config
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -44,9 +44,9 @@ requirements:
- bob.math
- bob.learn.activation
- bob.learn.linear
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -23,9 +23,9 @@ requirements:
- bob.core
- bob.io.base
- libblitz {{ libblitz }}
- libsvm 3.21|3.21.*
- libsvm {{ libsvm }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- cmake
- pkg-config
- gcc {{ gcc }} # [linux]
......@@ -37,10 +37,10 @@ requirements:
- bob.blitz
- bob.core
- bob.io.base
- libblitz 0.10|0.10.*
- libsvm 3.21|3.21.*
- boost 1.61.*
- numpy x.x
- libblitz
- libsvm
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -31,7 +31,7 @@ requirements:
- pkg-config
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -46,9 +46,9 @@ requirements:
# bob.io.matlab may be removed from dependencies in future
- bob.io.matlab
- scipy
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -28,7 +28,7 @@ requirements:
- pkg-config
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -40,9 +40,9 @@ requirements:
- bob.io.base
- bob.math
- bob.learn.activation
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- libgcc # [linux]
test:
......
......@@ -22,8 +22,8 @@ requirements:
- libblitz {{ libblitz }}
- boost {{ boost }}
- cmake
- numpy x.x
- mkl
- numpy {{ numpy }}
- mkl {{ mkl }}
- pkg-config
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -31,9 +31,9 @@ requirements:
run:
- python
- bob.core
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- mkl
- libgcc # [linux]
......
......@@ -32,7 +32,7 @@ requirements:
- pkg-config
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- numpy {{ numpy }}
- docopt
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
......@@ -45,9 +45,9 @@ requirements:
- bob.math
- bob.io.base
- matplotlib
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libblitz
- boost
- numpy {{ numpy }}
- docopt
- libgcc # [linux]
......