Commit 5241cb20 authored by Amir MOHAMMADI's avatar Amir MOHAMMADI
Browse files

Merge branch 'drop-free-channel' into 'master'

Drop free channel when building bob.conda

See merge request bob/bob.conda!420
parents 0572ce47 35debc58
Pipeline #32372 passed with stage
in 49 minutes and 37 seconds
......@@ -2,7 +2,7 @@
{% set nopin = ['ca-certificates', 'certifi', 'openssl', 'libstdcxx-ng', 'libgcc-ng', 'libcxx', 'libcxxabi'] %}
package:
name: beat-devel
version: 2019.08.07
version: 2019.08.08
build:
# the build number must be zero all the time.
......@@ -15,7 +15,7 @@ build:
requirements:
host:
- python {{ python }}
- bob-devel 2019.08.04
- bob-devel 2019.08.08
- docker-py 4.0.2
- flask 1.0.2
- flask-cors 3.0.7
......
......@@ -4,7 +4,7 @@ package:
name: bob-devel
# please update the version of beat-devel and update bob-devel's version there
# as well in the same merge request.
version: 2019.08.04
version: 2019.08.08
build:
# the build number must be zero all the time.
......@@ -17,60 +17,64 @@ build:
requirements:
host:
- python {{ python }}
# IMPORTANT: To update this list, create a conda environment with all the below
# packages without any pinning. Once the environment is resolved, observe those
# versions and put them here.
# Dependency list of bob packages. Everything is pinned to allow for better
# reproducibility. Please keep this list sorted. It is recommended that you
# update all dependencies at once (to their latest version) each time you
# modify the dependencies here. Use ``conda search`` to find the latest
# version of packages.
# reproducibility.
- boost 1.67.0
- caffe 1.0 # [linux]
- click 7.0
- click-plugins 1.0.4
- click-plugins 1.1.1
- cmake 3.14.0
- coverage 4.5.3
- cyvlfeat 0.4.6
- docopt 0.6.2
- ffmpeg 4.0
# to make sure we get ffmpeg from our own channel which has more codecs
- ffmpeg 4.0 hadceb68_1 # [linux]
- ffmpeg 4.0 h2047f9e_1 # [osx]
- freetype 2.9.1
- giflib 5.1.4
- hdf5 1.10.2
- jinja2 2.10.1
- jpeg 9b
- kaldi 2017.03.13 # [linux]
- kaldi 1!5.5.164 # [linux]
- libblitz 1.0.1
- libmatio 1.5.15
- libogg 1.3.2
- libpng 1.6.36
- libpng 1.6.37
- libsvm 3.22
- libtiff 4.0.10
- madmom 0.16.1
- matplotlib 3.0.3
- mkl 2019.3
- matplotlib 3.1.0
- menpo 0.8.1
- menpofit 0.5.0
- mkl 2019.4
- mne 0.15.2
- mr.developer 1.38
- nose 1.3.7
- numpy 1.16.2
- numpy 1.16.4
- opencv 3.4.2
- pillow 5.4.1
- pillow 6.1.0
- pkg-config 0.29.2
- pyedflib 0.1.11
- cudatoolkit 9.0 # [linux]
- pytorch 1.0.1 # [linux]
- pyyaml 5.1
- requests 2.21.0
- pytorch 1.1.0 # [linux]
- pyyaml 5.1.1
- requests 2.22.0
- schema 0.6.8
- scikit-image 0.14.2
- scikit-learn 0.20.3
- scikit-image 0.15.0
- scikit-learn 0.21.2
- scipy 1.2.1
- setuptools 41.0.0
- setuptools 41.0.1
- six 1.12.0
- sox 14.4.2
- sphinx 1.8.5
- sphinx 2.1.2
- sphinx_rtd_theme 0.4.3
- sqlalchemy 1.3.1
- sqlalchemy 1.3.5
- tabulate 0.8.3
- tensorflow 1.13.1
- torchvision 0.2.1 # [linux and py<37]
- tensorflow 1.14.0
- torchvision 0.3.0 # [linux]
- vlfeat 0.9.21
- zc.buildout 2.12.2
- zc.recipe.egg 2.0.7
......@@ -78,8 +82,6 @@ requirements:
- termcolor 1.1.0
# semi-supported dependencies (drop them if they conflict):
- dlib 19.7
- menpo 0.8.1
- menpofit 0.5.0
run:
- python
run_constrained:
......
......@@ -20,8 +20,6 @@ source:
build:
number: 2
skip: True # [blas_impl == 'mkl' and win]
requires_features:
blas: {{ mkl }}
requirements:
build:
......
......@@ -15,8 +15,6 @@ source:
build:
number: 0
skip: True # [not linux]
requires_features:
blas: {{ blas_impl }}
run_exports:
- {{ pin_subpackage(name, max_pin='x.x') }}
......
{% set name = "madmom" %}
{% set version = "0.16.1" %}
package:
name: '{{ name|lower }}'
version: '{{ version }}'
source:
git_rev: v{{ version }}
git_url: https://github.com/CPJKU/madmom
build:
number: 0
script: python setup.py install --single-version-externally-managed --record=record.txt
requirements:
build:
- {{ compiler('c') }}
- {{ compiler('cxx') }}
host:
- python
- setuptools
- numpy {{ numpy }}
- scipy {{ scipy }}
- cython {{ cython }}
- pytest-runner
run:
- python
- setuptools
- {{ pin_compatible('numpy') }}
- scipy >=0.16
- mido
test:
imports:
- madmom
- madmom.audio
- madmom.evaluation
- madmom.features
- madmom.ml
- madmom.ml.nn
- madmom.models
- madmom.utils
about:
home: https://github.com/CPJKU/madmom
license: BSD License
license_family: BSD
license_file: ''
summary: Python audio signal processing library
description: "Madmom is an audio signal processing library written in Python with a strong focus on music information retrieval (MIR) tasks."
doc_url: 'https://madmom.readthedocs.io/'
dev_url: 'https://github.com/CPJKU/madmom'
extra:
recipe-maintainers: amohammadi
{% set name = "mido" %}
{% set version = "1.2.9" %}
package:
name: '{{ name|lower }}'
version: '{{ version }}'
source:
git_rev: {{ version }}
git_url: https://github.com/mido/mido
build:
number: 0
script: python setup.py install --single-version-externally-managed --record=record.txt
requirements:
host:
- python
- setuptools
run:
- python
- setuptools
test:
imports:
- mido
source_files:
- tests/*
requires:
- pytest
commands:
- pytest tests
about:
home: https://github.com/mido/mido
license: MIT License
license_family: MIT
license_file: ''
summary: MIDI Objects for Python
description: "MIDI Objects for Python"
doc_url: 'https://mido.readthedocs.io'
dev_url: 'https://github.com/mido/mido'
extra:
recipe-maintainers: amohammadi
macos_min_version:
- 10.9
macos_machine:
- x86_64-apple-darwin13.4.0
MACOSX_DEPLOYMENT_TARGET:
- 10.9
CONDA_BUILD_SYSROOT: # [osx]
- /opt/MacOSX10.9.sdk # [osx]
# This helps CMAKE find the sysroot. See
# https://cmake.org/cmake/help/v3.11/variable/CMAKE_OSX_SYSROOT.html
SDKROOT: # [osx]
- /opt/MacOSX10.9.sdk # [osx]
# makes autotools verbose
VERBOSE_AT:
- V=1
# makes cmake verbose
VERBOSE_CM:
- VERBOSE=1
# the blas implementations that we build against
blas_impl:
- mkl
pin_run_as_build:
libboost:
max_pin: x.x.x
py_boost:
max_pin: x.x.x
boost:
max_pin: x.x.x
## the dependencies that we build against multiple versions
python:
- 3.6
- 3.7
zip_keys:
- # [win]
- vc # [win]
- c_compiler # [win]
- cxx_compiler # [win]
- fortran_compiler_version # [win]
- python # [win]
numpy:
- 1.15.4
boost:
- 1.67.0
cython:
- 0.29.12
ffmpeg:
- 4.0
hdf5:
- 1.10.2
- 1.10.4
jpeg:
- 9b
libogg:
- 1.3.2
libpng:
- 1.6.35
mkl:
- 2019.1
openblas:
- 0.3.3
openfst:
- 1.6.7
scipy:
- 1.2.1
setuptools:
- 41.0.0
speex:
- 1.2.0
speexdsp:
- 1.2rc3
sqlite:
- 3.29.0
vlfeat:
- 0.9.21
xz:
- 5.2.3
zlib:
- 1.2.11
default_channels:
- https://repo.anaconda.com/pkgs/main
add_pip_as_python_dependency: false #!final
always_yes: true #!final
quiet: true #!final
show_channel_urls: true #!final
anaconda_upload: false #!final
ssl_verify: false #!final
remote_connect_timeout_secs: 120.0 #!final
remote_max_retries: 50 #!final
remote_read_timeout_secs: 180.0 #!final
channels:
- defaults
......@@ -9,8 +9,6 @@ conda/zc.recipe.egg
conda/mr.developer
conda/pyedflib
conda/schema
conda/mido
conda/madmom
conda/oset
conda/sphinxcontrib-programoutput
conda/sphinxcontrib-httpdomain
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment