Commit 503cbd0e authored by Amir Mohammadi's avatar Amir Mohammadi
Browse files

use the packaged gcc

parent 1f193061
Pipeline #6242 failed with stages
in 7 minutes and 40 seconds
......@@ -37,14 +37,11 @@ build-linux-64:
<<: *build_job
before_script:
- export PATH=/usr/local/bin:/opt/miniconda/bin:$PATH
- export LD_LIBRARY_PATH=/usr/local/lib64:/usr/local/lib:/opt/miniconda/lib:$LD_LIBRARY_PATH
- export LIBRARY_PATH=/usr/local/lib64:/usr/local/lib:/opt/miniconda/lib:$LIBRARY_PATH
- unset CFLAGS CXXFLAGS
- export PATH=/opt/miniconda/bin:/usr/local/bin:$PATH
- export LD_LIBRARY_PATH=/opt/miniconda/lib:/usr/local/lib64:/usr/local/lib:$LD_LIBRARY_PATH
- export LIBRARY_PATH=/opt/miniconda/lib:/usr/local/lib64:/usr/local/lib:$LIBRARY_PATH
- export INCLUDE=/opt/miniconda/include:$INCLUDE
- export CFLAGS="${CFLAGS} -Wabi=2"
- export CFLAGS="${CFLAGS} -D_GLIBCXX_USE_CXX11_ABI=0"
- export CXXFLAGS="${CXXFLAGS} -Wabi=2"
- export CXXFLAGS="${CXXFLAGS} -D_GLIBCXX_USE_CXX11_ABI=0"
artifacts:
paths:
......@@ -62,12 +59,8 @@ build-osx-64:
before_script:
- rm -f ~/.condarc || true
- rm -f /opt/conda/.condarc || true
- unset CC CXX FC CFLAGS CXXFLAGS LIBRARY_PATH C_INCLUDE_PATH
- export PATH=/opt/conda/bin:$PATH
- export CC="/usr/local/bin/gcc-4.2"
- export CXX="/usr/local/bin/g++-4.2"
- export FC="/usr/local/bin/gfortran-4.2.3"
- export LIBRARY_PATH=/Developer/SDKs/MacOSX10.7.sdk/usr/lib:/Developer/SDKs/MacOSX10.7.sdk/usr/lib/system
- export C_INCLUDE_PATH=/Developer/SDKs/MacOSX10.7.sdk/usr/include
- export MACOSX_VERSION_MIN="10.7"
- export MACOSX_DEPLOYMENT_TARGET="${MACOSX_VERSION_MIN}"
- export CMAKE_OSX_DEPLOYMENT_TARGET="${MACOSX_VERSION_MIN}"
......
......@@ -28,9 +28,12 @@ requirements:
- yasm
- x264 20131217
- zlib 1.2.8
- gcc 4.8.5
run:
- x264 20131217
- zlib >=1.2.8,<1.3
- libgcc >=4.8.5
test:
commands:
......
......@@ -21,6 +21,13 @@ build:
- C_INCLUDE_PATH # [osx]
skip: True # [win]
requirements:
build:
- gcc 4.8.5
run:
- libgcc >=4.8.5
test:
commands:
- gif2rgb -h
......
......@@ -21,6 +21,12 @@ build:
- C_INCLUDE_PATH # [osx]
skip: true # [win]
requirements:
build:
- gcc 4.8.5
run:
- libgcc >=4.8.5
test:
commands:
- test -d $PREFIX/include/blitz # [unix]
......
......@@ -24,10 +24,12 @@ requirements:
build:
- hdf5 1.8.17|1.8.17.*
- zlib 1.2.8
- gcc 4.8.5
run:
- hdf5 1.8.17|1.8.17.*
- zlib >=1.2.8,<1.3
- libgcc >=4.8.5
test:
commands:
......
......@@ -31,6 +31,10 @@ build:
requirements:
build:
- python # [win]
- gcc 4.8.5
run:
- libgcc >=4.8.5
test:
requires:
......
......@@ -27,11 +27,13 @@ requirements:
- libpng 1.6.22
- zlib 1.2.8
- xz 5.2.2
- gcc 4.8.5
run:
- libpng >=1.6.22,<1.7
- zlib >=1.2.8,<1.3
- xz >=5.2.2,<6.0
- libgcc >=4.8.5
test:
commands:
......
......@@ -33,6 +33,10 @@ build:
requirements:
build:
- python # [win]
- gcc 4.8.5
run:
- libgcc >=4.8.5
test:
requires:
......
......@@ -24,10 +24,10 @@ build:
requirements:
build:
- yasm
- gcc # [osx]
- gcc 4.8.5
run:
- libgcc # [osx]
- libgcc >=4.8.5
test:
commands:
......
......@@ -28,6 +28,10 @@ build:
requirements:
build:
- python # [unix]
- gcc 4.8.5
run:
- libgcc >=4.8.5
test:
commands:
......
......@@ -34,6 +34,7 @@ requirements:
- scipy
- cmake
- pkg-config
- gcc 4.8.5
run:
- python
......@@ -43,6 +44,7 @@ requirements:
- bob.sp
- numpy
- scipy
- libgcc >=4.8.5
test:
imports:
......
......@@ -31,6 +31,7 @@ requirements:
- libblitz 0.10|0.10.*
- boost 1.61.*
- cmake
- gcc 4.8.5
run:
- python
......@@ -38,6 +39,7 @@ requirements:
- numpy x.x
- libblitz 0.10|0.10.*
- boost 1.61.*
- libgcc >=4.8.5
test:
requires:
......
......@@ -29,11 +29,13 @@ requirements:
- pkg-config
- bob.blitz
- boost 1.61.*
- gcc 4.8.5
run:
- python
- bob.blitz
- boost 1.61.*
- libgcc >=4.8.5
test:
requires:
......
......@@ -34,6 +34,7 @@ requirements:
- boost 1.61.*
- sox 14.4.2
- pkg-config
- gcc 4.8.5
run:
- python
......@@ -45,6 +46,7 @@ requirements:
- bob.io.matlab
- boost 1.61.*
- sox 14.4.2
- libgcc >=4.8.5
test:
imports:
......
......@@ -32,6 +32,7 @@ requirements:
- cmake
- pkg-config
- boost 1.61.*
- gcc 4.8.5
run:
- python
......@@ -40,6 +41,7 @@ requirements:
- bob.core
- hdf5 1.8.17|1.8.17.*
- boost 1.61.*
- libgcc >=4.8.5
test:
imports:
......
......@@ -37,6 +37,7 @@ requirements:
- boost 1.61.*
- cmake
- pkg-config
- gcc 4.8.5
run:
- python
......@@ -50,6 +51,7 @@ requirements:
- jpeg 8d
- libtiff >=4.0.6,<5
- boost 1.61.*
- libgcc >=4.8.5
test:
commands:
......
......@@ -32,6 +32,7 @@ requirements:
- libmatio 1.5.*
- pkg-config
- boost 1.61.*
- gcc 4.8.5
run:
- python
......@@ -41,6 +42,7 @@ requirements:
- bob.io.base
- libmatio 1.5.*
- boost 1.61.*
- libgcc >=4.8.5
test:
imports:
......
......@@ -36,6 +36,7 @@ requirements:
- boost 1.61.*
- pkg-config
- olefile
- gcc 4.8.5
run:
- python
......@@ -46,6 +47,7 @@ requirements:
- bob.io.base
- ffmpeg >=2.8.10,<2.9
- boost 1.61.*
- libgcc >=4.8.5
test:
commands:
......
......@@ -36,6 +36,7 @@ requirements:
- boost 1.61.*
- cmake
- pkg-config
- gcc 4.8.5
run:
- python
......@@ -48,6 +49,7 @@ requirements:
- bob.math
- vlfeat 0.9.20
- boost 1.61.*
- libgcc >=4.8.5
test:
commands:
......
......@@ -32,6 +32,7 @@ requirements:
- cmake
- pkg-config
- boost 1.61.*
- gcc 4.8.5
run:
- python
......@@ -40,6 +41,7 @@ requirements:
- bob.core
- bob.io.base
- boost 1.61.*
- libgcc >=4.8.5
test:
commands:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment