Commit 4cb9a847 authored by Amir MOHAMMADI's avatar Amir MOHAMMADI

[bobs] general pin gcc and libgcc

parent 225c7e00
......@@ -45,10 +45,10 @@ A few remarks:
requirements:
build:
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- libgcc 4.8.5 # [linux]
- libgcc # [linux]
```
......
......@@ -20,8 +20,8 @@ requirements:
- toolchain {{ toolchain }}
- zlib 1.2.8
- xz 5.2.2
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- zlib >=1.2.8,<1.3
......
......@@ -14,8 +14,8 @@ build:
requirements:
build:
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
- python
- setuptools
- numpy x.x
......@@ -27,7 +27,7 @@ requirements:
- python
- vlfeat 0.9.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
requires:
......
......@@ -21,8 +21,8 @@ requirements:
build:
- python
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
- cmake
- mkl # [not win]
- numpy x.x
......@@ -33,7 +33,7 @@ requirements:
run:
- python
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
- mkl # [not win]
- numpy x.x
- boost 1.61.*
......
......@@ -21,11 +21,11 @@ requirements:
- toolchain {{ toolchain }}
- cmake
- python # [win]
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
files:
......
......@@ -16,11 +16,11 @@ build:
requirements:
build:
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -15,13 +15,13 @@ build:
requirements:
build:
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
- openfst
- openblas
- speex
run:
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
- openfst
- openblas
- speex
......
......@@ -16,10 +16,10 @@ build:
requirements:
build:
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -17,13 +17,13 @@ requirements:
- toolchain {{ toolchain }}
- hdf5 1.8.17|1.8.17.*
- zlib 1.2.8
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- hdf5 1.8.17|1.8.17.*
- zlib >=1.2.8,<1.3
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -27,10 +27,10 @@ requirements:
- vc 14 # [win and py35]
- pkgconfig # [unix]
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
- vc 9 # [win and py27]
- vc 10 # [win and py34]
- vc 14 # [win and py35]
......
......@@ -24,11 +24,11 @@ requirements:
build:
- toolchain {{ toolchain }}
- python # [win]
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
requires:
......
......@@ -18,8 +18,8 @@ build:
requirements:
build:
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
- python
- setuptools
- numpy x.x
......@@ -29,7 +29,7 @@ requirements:
- python
- pathlib 1.0 # [py2k]
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
# Scientific Python Stack
- scipy
......
......@@ -36,8 +36,8 @@ requirements:
- libtiff {{ libtiff }}
- libpng {{ libpng }}
- msinttypes # [win and py<35]
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -47,7 +47,7 @@ requirements:
- libpng >=1.6.27,<1.7
- jpeg 9b
- libtiff >=4.0.6,<5
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
imports:
......
......@@ -23,8 +23,8 @@ build:
requirements:
build:
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
- git
- cmake # [win]
- autoconf # [unix]
......@@ -38,7 +38,7 @@ requirements:
- ordereddict # [py26]
- unittest2 # [py26]
run:
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
- zlib 1.2.*
- python
- setuptools
......
......@@ -15,8 +15,8 @@ build:
requirements:
build:
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
- python
- setuptools
- numpy x.x
......@@ -25,7 +25,7 @@ requirements:
run:
- python
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
requires:
......
......@@ -20,14 +20,14 @@ requirements:
- libpng {{ libpng }}
- zlib 1.2.8
- xz 5.2.2
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- libpng >=1.6.27,<1.7
- zlib >=1.2.8,<1.3
- xz >=5.2.2,<6.0
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -17,12 +17,12 @@ build:
requirements:
build:
- toolchain {{ toolchain }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
- libogg
run:
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
- libogg
test:
......
......@@ -27,8 +27,8 @@ requirements:
- scipy
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -39,7 +39,7 @@ requirements:
- libblitz 0.10|0.10.*
- numpy x.x
- scipy
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
imports:
......
......@@ -24,8 +24,8 @@ requirements:
- libblitz {{ libblitz }}
- boost {{ boost }}
- cmake
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -33,7 +33,7 @@ requirements:
- numpy x.x
- libblitz 0.10|0.10.*
- boost 1.61.*
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
requires:
......
......@@ -24,8 +24,8 @@ requirements:
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -33,7 +33,7 @@ requirements:
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
requires:
......
......@@ -36,9 +36,9 @@ test:
- numpy
- sphinx_rtd_theme
- sphinx
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- toolchain {{ toolchain }}
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
- bob.buildout
imports:
......
......@@ -29,8 +29,8 @@ requirements:
- sox 14.4.2
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -44,7 +44,7 @@ requirements:
- boost 1.61.*
- sox 14.4.2
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
imports:
......
......@@ -27,8 +27,8 @@ requirements:
- pkg-config
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -39,7 +39,7 @@ requirements:
- hdf5 1.8.17|1.8.17.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
imports:
......
......@@ -32,8 +32,8 @@ requirements:
- numpy x.x
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -49,7 +49,7 @@ requirements:
- libtiff >=4.0.6,<5
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -27,8 +27,8 @@ requirements:
- pkg-config
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -40,7 +40,7 @@ requirements:
- libmatio 1.5.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
imports:
......
......@@ -31,8 +31,8 @@ requirements:
- numpy x.x
- pkg-config
- olefile
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -45,7 +45,7 @@ requirements:
- ffmpeg >=2.8.10,<2.9
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -31,8 +31,8 @@ requirements:
- numpy x.x
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -47,7 +47,7 @@ requirements:
- vlfeat 0.9.20
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -27,8 +27,8 @@ requirements:
- pkg-config
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -39,7 +39,7 @@ requirements:
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -23,8 +23,8 @@ requirements:
- libblitz {{ libblitz }}
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -32,7 +32,7 @@ requirements:
- bob.blitz
- libblitz 0.10|0.10.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -35,8 +35,8 @@ requirements:
- boost {{ boost }}
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -48,7 +48,7 @@ requirements:
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -31,8 +31,8 @@ requirements:
- boost {{ boost }}
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -48,7 +48,7 @@ requirements:
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -29,8 +29,8 @@ requirements:
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -43,7 +43,7 @@ requirements:
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -28,8 +28,8 @@ requirements:
- libblitz {{ libblitz }}
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -42,7 +42,7 @@ requirements:
- scipy
- libblitz 0.10|0.10.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -29,8 +29,8 @@ requirements:
- libblitz {{ libblitz }}
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -42,7 +42,7 @@ requirements:
- bob.ip.color
- libblitz 0.10|0.10.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -29,8 +29,8 @@ requirements:
- numpy x.x
- scipy
- libblitz {{ libblitz }}
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -45,7 +45,7 @@ requirements:
- numpy x.x
- scipy
- libblitz 0.10|0.10.*
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -27,8 +27,8 @@ requirements:
- numpy x.x
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -39,7 +39,7 @@ requirements:
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -30,8 +30,8 @@ requirements:
- numpy x.x
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -43,7 +43,7 @@ requirements:
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -31,8 +31,8 @@ requirements:
- libblitz {{ libblitz }}
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -47,7 +47,7 @@ requirements:
- libblitz 0.10|0.10.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -28,8 +28,8 @@ requirements:
- numpy x.x
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- gcc {{ gcc }} # [linux]
- libgcc {{ libgcc }} # [linux]
run:
- python
......@@ -41,7 +41,7 @@ requirements:
- libsvm 3.21|3.21.*
- boost 1.61.*
- numpy x.x
- libgcc >=4.8.5 # [linux]
- libgcc # [linux]
test:
commands:
......
......@@ -32,8 +32,8 @@ requirements:
- libblitz {{ libblitz }}
- boost {{ boost }}