Commit 4922175f authored by Amir MOHAMMADI's avatar Amir MOHAMMADI

[bob-devel][beat-devel] update pins

parent cadec323
Pipeline #44855 failed with stage
in 7 minutes and 59 seconds
......@@ -16,13 +16,16 @@ requirements:
host:
- bob-devel 2020.10.28
- python {{ python }}
- docker-py 4.3.1
- jsonschema 3.2.0
- ncurses 6.2
- python-graphviz 0.14.2
- pyzmq 19.0.2
- simplejson 3.17.2
- sphinxcontrib-httpdomain 1.7.0
# the dependencies are pinned in bob-devel
- docker-py
- jsonschema
- ncurses
- psycopg2
- python-graphviz
- pyzmq
- simplejson
- sphinxcontrib-httpdomain
- termcolor
run:
- python
run_constrained:
......
......@@ -17,62 +17,66 @@ build:
requirements:
host:
- python {{ python }}
# Dependency list of bob and beat packages. Everything is pinned to allow
# for better reproducibility.
# IMPORTANT: To update this list, create a conda environment with all the
# below packages without any pinning. Once the environment is resolved,
# observe those versions and put them here.
# Dependency list of bob packages. Everything is pinned to allow for better
# reproducibility.
- boost 1.73.0
- click 7.1.2
- click-plugins 1.1.1
- cmake 3.14.0
- coverage 5.3
- docker-py 4.3.1
- docopt 0.6.2
- ffmpeg 4.2.2
- freetype 2.10.4
- giflib 5.2.1
- h5py 2.10.0
- hdf5 1.10.4
- hdf5 1.10.6
- jinja2 2.11.2
- jpeg 9b
- jsonschema 3.2.0
- libblitz 1.0.1
- libpng 1.6.37
- libsvm 3.24
- libtiff 4.1.0
- matplotlib 3.3.2
- mkl 2020.2
- ncurses 6.2
- nose 1.3.7
- numpy 1.19.2
- pandas 1.1.3
- pillow 8.0.1
- pkg-config 0.29.2
- psycopg2 2.8.5
- pybind11 2.5.0
- python-graphviz 0.14.2
- pytorch 1.7.0
- pyyaml 5.3.1
- pyzmq 19.0.2
- requests 2.24.0
- schema 0.7.2
- scikit-image 0.17.2
- scikit-learn 0.23.2
- scipy 1.5.2
- setuptools 50.3.0
- simplejson 3.17.2
- sox 14.4.2
- sphinx 3.2.1
- sphinx_rtd_theme 0.4.3
- sphinxcontrib-httpdomain 1.7.0
- sphinxcontrib-programoutput 0.16
- sqlalchemy 1.3.20
- tabulate 0.8.7
- tensorflow 2.2.0
- termcolor 1.1.0
- torchvision 0.8.1
- tqdm 4.50.2
- vlfeat 0.9.21
- zc.buildout 2.13.3
- zc.recipe.egg 2.0.7
# beat-devel direct dependencies that leak to bob-devel as indirect
# dependencies:
- termcolor 1.1.0
- psycopg2 2.8.5
# semi-supported dependencies (drop them if they conflict):
run:
- python
run_constrained:
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment