Commit 3b45613a authored by Amir MOHAMMADI's avatar Amir MOHAMMADI

[bobs] general pin gcc

parent 399f1589
......@@ -46,7 +46,7 @@ requirements:
build:
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- libgcc 4.8.5 # [linux]
......
......@@ -21,7 +21,7 @@ requirements:
- zlib 1.2.8
- xz 5.2.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- zlib >=1.2.8,<1.3
......
......@@ -15,7 +15,7 @@ requirements:
build:
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- python
- setuptools
- numpy x.x
......
......@@ -22,7 +22,7 @@ requirements:
- python
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- cmake
- mkl # [not win]
- numpy x.x
......
......@@ -22,7 +22,7 @@ requirements:
- cmake
- python # [win]
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
......
......@@ -17,7 +17,7 @@ requirements:
build:
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
......
......@@ -11,12 +11,12 @@ source:
build:
number: 0
skip: true # [not linux]
requirements:
build:
- toolchain 2.3.2
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- openfst
- openblas
- speex
......
......@@ -17,7 +17,7 @@ requirements:
build:
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
......
......@@ -18,7 +18,7 @@ requirements:
- hdf5 1.8.17|1.8.17.*
- zlib 1.2.8
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- hdf5 1.8.17|1.8.17.*
......
......@@ -28,9 +28,9 @@ requirements:
- pkgconfig # [unix]
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
- libgcc >=4.8.5 # [linux]
- vc 9 # [win and py27]
- vc 10 # [win and py34]
- vc 14 # [win and py35]
......@@ -57,7 +57,7 @@ about:
license_file: COPYING
summary: "OGG media container"
description: |
OGG media container. This is the native format and the recommended container
OGG media container. This is the native format and the recommended container
for Xiph codecs.
doc_url: https://wiki.xiph.org/
......
......@@ -25,7 +25,7 @@ requirements:
- toolchain 2.3.2
- python # [win]
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- libgcc >=4.8.5 # [linux]
......
......@@ -19,7 +19,7 @@ requirements:
build:
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- python
- setuptools
- numpy x.x
......
......@@ -37,7 +37,7 @@ requirements:
- libpng 1.6.27
- msinttypes # [win and py<35]
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -24,7 +24,7 @@ requirements:
build:
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- git
- cmake # [win]
- autoconf # [unix]
......
......@@ -16,7 +16,7 @@ requirements:
build:
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- python
- setuptools
- numpy x.x
......
......@@ -21,7 +21,7 @@ requirements:
- zlib 1.2.8
- xz 5.2.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- libpng >=1.6.27,<1.7
......
......@@ -18,11 +18,11 @@ requirements:
build:
- toolchain 2.3.2
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
- libogg
run:
- libgcc >=4.8.5 # [linux]
- libgcc >=4.8.5 # [linux]
- libogg
test:
......
......@@ -28,7 +28,7 @@ requirements:
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -25,7 +25,7 @@ requirements:
- boost {{ boost }}
- cmake
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -25,7 +25,7 @@ requirements:
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -30,7 +30,7 @@ requirements:
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -28,7 +28,7 @@ requirements:
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -33,7 +33,7 @@ requirements:
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -28,7 +28,7 @@ requirements:
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -32,7 +32,7 @@ requirements:
- pkg-config
- olefile
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -32,7 +32,7 @@ requirements:
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -28,7 +28,7 @@ requirements:
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -24,7 +24,7 @@ requirements:
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -36,7 +36,7 @@ requirements:
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -32,7 +32,7 @@ requirements:
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -30,7 +30,7 @@ requirements:
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -29,7 +29,7 @@ requirements:
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -30,7 +30,7 @@ requirements:
- numpy x.x
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -30,7 +30,7 @@ requirements:
- scipy
- libblitz {{ libblitz }}
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -28,7 +28,7 @@ requirements:
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -31,7 +31,7 @@ requirements:
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -32,7 +32,7 @@ requirements:
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -29,7 +29,7 @@ requirements:
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -33,7 +33,7 @@ requirements:
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -30,7 +30,7 @@ requirements:
- boost {{ boost }}
- numpy x.x
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -26,7 +26,7 @@ requirements:
- mkl
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -35,7 +35,7 @@ requirements:
- numpy x.x
- docopt
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
......@@ -26,7 +26,7 @@ requirements:
- cmake
- pkg-config
- gcc 4.8.5 # [linux]
- libgcc 4.8.5 # [linux]
- libgcc {{ gcc }} # [linux]
run:
- python
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment