Commit 265c7f98 authored by Amir MOHAMMADI's avatar Amir MOHAMMADI
Browse files

[bob-devel,beat-devel] update, ignore some pins

parent c764eaaf
Pipeline #23680 passed with stage
in 32 minutes and 50 seconds
# The original copy of this list is in bob-devel recipe. Keep them synced please.
{% set nopin = ['ca-certificates', 'certifi', 'openssl', 'libstdcxx-ng', 'libgcc-ng', 'libcxx', 'libcxxabi'] %}
package:
name: beat-devel
version: 2018.09.20
version: 2018.09.24
build:
# the build number must be zero all the time.
......@@ -13,7 +15,7 @@ build:
requirements:
host:
- python {{ python }}
- bob-devel 2018.09.20
- bob-devel 2018.09.24
- docker-py 3.2.1
- flask 0.12.2
- flask-cors 3.0.3
......@@ -30,7 +32,9 @@ requirements:
- python
run_constrained:
{% for package in resolved_packages('host') %}
{% if package.split()[0] not in nopin %}
- {{ package }}
{% endif %}
{% endfor %}
about:
......
# A copy of this list is in beat-devel as well. Keep them synced please.
{% set nopin = ['ca-certificates', 'certifi', 'openssl', 'libstdcxx-ng', 'libgcc-ng', 'libcxx', 'libcxxabi'] %}
package:
name: bob-devel
version: 2018.09.20
version: 2018.09.24
# please update the version of beat-devel and update bob-devel's version there
# as well in the same merge request.
......@@ -15,8 +17,6 @@ build:
requirements:
host:
- python {{ python }}
- {{ compiler('c') }}
- {{ compiler('cxx') }}
# Dependency list of bob packages. Everything is pinned to allow for better
# reproducibility. Please keep this list sorted. It is recommended that you
# update all dependencies at once (to their latest version) each time you
......@@ -26,13 +26,13 @@ requirements:
- caffe 1.0 # [linux]
- click 6.7
- click-plugins 1.0.3
- cmake 3.11.1
- cmake 3.12.2
- coverage 4.5.1
- cyvlfeat 0.4.6
- dlib 19.7
- docopt 0.6.2
- ffmpeg 3.4
- freetype 2.8
- freetype 2.9.1
- giflib 5.1.4
- hdf5 1.10.1
- jinja2 2.10
......@@ -45,33 +45,33 @@ requirements:
- libsvm 3.22
- libtiff 4.0.9
- madmom 0.15.1
- matplotlib 2.2.2
- matplotlib 2.2.3
- menpo 0.8.1
- menpofit 0.5.0
- mkl 2018.0.3
- mkl 2019.0
- mne 0.15.2
- mr.developer 1.38
- nose 1.3.7
- numpy 1.14.5
- numpy 1.15.1
- opencv 3.3.1
- pillow 4.3.0
- pillow 5.2.0
- pkg-config 0.29.2
- pyedflib 0.1.11
- pytorch 0.4 # [linux]
- pyyaml 3.12
- pytorch 0.4.1 # [linux]
- pyyaml 3.13
- requests 2.19.1
- schema 0.6.7
- scikit-image 0.14.0
- scikit-learn 0.19.1
- scikit-learn 0.19.2
- scipy 1.1.0
- setuptools 39.2.0
- setuptools 40.2.0
- six 1.11.0
- sox 14.4.2
- sphinx 1.6.3
- sphinx_rtd_theme 0.4.0
- sqlalchemy 1.2.8
- sphinx 1.7.9
- sphinx_rtd_theme 0.4.1
- sqlalchemy 1.2.11
- tabulate 0.8.2
- tensorflow 1.8.0 # [linux]
- tensorflow 1.9.0 # [linux]
- torchvision 0.2.1 # [linux]
- vlfeat 0.9.21
- zc.buildout 2.11.2
......@@ -80,7 +80,9 @@ requirements:
- python
run_constrained:
{% for package in resolved_packages('host') %}
{% if package.split()[0] not in nopin %}
- {{ package }}
{% endif %}
{% endfor %}
about:
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment