Commit bc76ec17 authored by Manuel Günther's avatar Manuel Günther
Browse files

Removed bob.core from the dependencies.

parent 1cdc12e0
......@@ -14,9 +14,8 @@ matrix:
- NUMPYSPEC===1.8.0
before_install:
- sudo add-apt-repository -y ppa:biometrics/bob
- sudo add-apt-repository -y ppa:biometrics/bob.preview
- sudo apt-get update -qq
- sudo apt-get install -qq --force-yes bob-dev
- sudo apt-get install -qq --force-yes libblitz1-dev
- if [ -n "${NUMPYSPEC}" ]; then sudo apt-get install -qq libatlas-dev libatlas-base-dev
liblapack-dev gfortran; fi
- if [ -n "${NUMPYSPEC}" ]; then pip install --upgrade pip setuptools; fi
......
......@@ -5,7 +5,11 @@
* @brief Binds configuration information available from bob
*/
#include <Python.h>
#ifdef NO_IMPORT_ARRAY
#undef NO_IMPORT_ARRAY
#endif
#include <bob.blitz/capi.h>
#include <bob.blitz/cleanup.h>
#include <string>
#include <cstdlib>
......@@ -14,12 +18,6 @@
#include <boost/version.hpp>
#include <boost/format.hpp>
#ifdef NO_IMPORT_ARRAY
#undef NO_IMPORT_ARRAY
#endif
#include <bob.blitz/capi.h>
#include <bob.blitz/cleanup.h>
static int dict_set(PyObject* d, const char* key, const char* value) {
PyObject* v = Py_BuildValue("s", value);
if (!v) return 0;
......
......@@ -10,7 +10,6 @@ extensions = bob.buildout
auto-checkout = *
develop = src/bob.extension
src/bob.blitz
src/bob.core
.
; options for bob.buildout extension
......@@ -20,7 +19,6 @@ verbose = true
[sources]
bob.extension = git https://github.com/bioidiap/bob.extension
bob.blitz = git https://github.com/bioidiap/bob.blitz
bob.core = git https://github.com/bioidiap/bob.core
[scripts]
recipe = bob.buildout:scripts
......@@ -4,7 +4,7 @@
# Thu 30 Jan 08:45:49 2014 CET
from setuptools import setup, find_packages, dist
dist.Distribution(dict(setup_requires=['bob.blitz', 'bob.core']))
dist.Distribution(dict(setup_requires=['bob.blitz']))
from bob.blitz.extension import Extension
import os
......@@ -47,7 +47,6 @@ setup(
],
version = version,
packages = packages,
bob_packages = ['bob.core'],
include_dirs = [include_dir]
),
Extension("bob.ip.draw._library",
......@@ -61,7 +60,6 @@ setup(
],
packages = packages,
version = version,
bob_packages = ['bob.core'],
include_dirs = [include_dir]
),
],
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment