Commit cbeca8f1 authored by André Anjos's avatar André Anjos 💬
Browse files

Update on dependencies

parent 61ede3eb
......@@ -17,6 +17,7 @@ before_install:
- sudo add-apt-repository -y ppa:biometrics/bob.preview
- sudo apt-get update -qq
- sudo apt-get install -qq --force-yes bob-dev libavcodec-dev libavformat-dev libswscale-dev
- sudo apt-get install -qq python-imaging
- if [ -n "${NUMPYSPEC}" ]; then sudo apt-get install -qq libatlas-dev libatlas-base-dev liblapack-dev gfortran; fi
- if [ -n "${NUMPYSPEC}" ]; then pip install --upgrade pip setuptools; fi
- if [ -n "${NUMPYSPEC}" ]; then pip install --find-links http://wheels.astropy.org/ --find-links http://wheels2.astropy.org/ --use-wheel numpy$NUMPYSPEC sphinx nose; fi
......
......@@ -18,8 +18,18 @@ packages = [
'libavutil >= 49.15.0',
'libswscale >= 0.7.1'
]
version = '2.0.0a0'
# Check if python-imaging means pil or pillow
pil_or_pillow = []
try:
import pkg_resources
pkg_resources.require('PIL')
pil_or_pillow.append('pil')
except pkg_resources.DistributionNotFound as e:
pil_or_pillow.append('pillow')
setup(
name='xbob.io.video',
......@@ -39,7 +49,7 @@ setup(
'setuptools',
'xbob.blitz',
'xbob.io.base',
],
] + pil_or_pillow,
namespace_packages=[
"xbob",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment