Sphinx 3 autodoc no longer accepts autodoc_default_flags and autodoc_default_options should be used

5 jobs for master in 3 minutes and 38 seconds (queued for 2 seconds)
latest
Status Job ID Name Coverage
  Build
failed #217609
docker
build_linux_36

00:03:34

failed #217610
docker
build_linux_37

00:03:31

failed #217607
macosx
build_macosx_36

00:02:56

failed #217608
macosx
build_macosx_37

00:02:50

 
  Deploy
skipped #217611
docker
deploy_beta
 
Name Stage Failure
failed
build_linux_36 Build
  File "/scratch/builds/bob/bob.db.uvad/miniconda/lib/python3.7/site-packages/conda_build/environ.py", line 804, in get_install_actions
raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform linux-64: {"python[version='>=3.9,<3.10.0a0']", 'setuptools', "python[version='>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.9,<3.10.0a0|>=3.7,<3.8.0a0']", "bob.extension[version='>=5.0.2b.0,<6.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", "python[version='>=3.5|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", 'sqlalchemy', "mkl[version='>=2019.4,<2021.0a0']", '_libgcc_mutex=[build=main]', "bob.db.base[version='>=3.0.6b.0,<4.0a0']", "giflib[version='>=5.1.4,<5.2.0a0|>=5.2.1,<5.3.0a0']", "bob.io.base[version='>=3.0.10b.0,<4.0a0']", 'tzdata', 'ca-certificates', "python[version='>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "numpy-base[version='1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.17.2.*|1.17.3.*|1.17.4.*|1.18.1.*|1.18.5.*|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.2',build='py36h2f8d375_0|py38hde5b4d6_0|py37hfa32c7d_0|py38h75fe3a5_0|py36h75fe3a5_0|py36hfa32c7d_0|py38hfa32c7d_0|py37h75fe3a5_0|py37hfa32c7d_0|py37h75fe3a5_0|py36h75fe3a5_0|py36hfa32c7d_0|py38hfa32c7d_0|py38h75fe3a5_0|py38h2f8d375_0|py36hde5b4d6_0|py37hde5b4d6_0|py37h2f8d375_0']", "six[version='>=1.5']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']", "bob.pad.base[version='>=2.3.2b.0,<3.0a0']", 'python', 'six'}
Uploading artifacts for failed job
Uploading artifacts...
WARNING: coverage.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
build_linux_37 Build
  File "/scratch/builds/bob/bob.db.uvad/miniconda/lib/python3.7/site-packages/conda_build/environ.py", line 804, in get_install_actions
raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform linux-64: {'_libgcc_mutex=[build=main]', 'setuptools', 'python', "python[version='>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", "blas[version='*|1.0',build='mkl|openblas']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']", 'ca-certificates', "six[version='>=1.5']", 'tzdata', "bob.extension[version='>=5.0.2b.0,<6.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.9,<3.10.0a0|>=3.7,<3.8.0a0']", "libpng[version='>=1.6.35,<1.7.0a0|>=1.6.37,<1.7.0a0']", "python[version='>=3.9,<3.10.0a0']", "python[version='>=3.5|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", "bob.io.base[version='>=3.0.10b.0,<4.0a0']", "bob.pad.base[version='>=2.3.2b.0,<3.0a0']", "bob.db.base[version='>=3.0.6b.0,<4.0a0']", 'six', 'sqlalchemy', "numpy-base[version='1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.17.2.*|1.17.3.*|1.17.4.*|1.18.1.*|1.18.5.*|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.2',build='py37h2f8d375_0|py36h2f8d375_0|py36hde5b4d6_0|py38h2f8d375_0|py37hfa32c7d_0|py38h75fe3a5_0|py38hfa32c7d_0|py38h75fe3a5_0|py38hfa32c7d_0|py36hfa32c7d_0|py36h75fe3a5_0|py37h75fe3a5_0|py37hfa32c7d_0|py37h75fe3a5_0|py36h75fe3a5_0|py36hfa32c7d_0|py38hde5b4d6_0|py37hde5b4d6_0']"}
Uploading artifacts for failed job
Uploading artifacts...
WARNING: coverage.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
build_macosx_36 Build
    raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform osx-64: {"python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.7,<3.8.0a0']", "python[version='>=3.5|>=3.7,<3.8.0a0|>=3.6,<3.7.0a0']", "python[version='>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "bob.extension[version='>=5.0.2b.0,<6.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", 'setuptools', 'python', 'tzdata', "bob.pad.base[version='>=2.3.2b.0,<3.0a0']", 'ca-certificates', "bob.db.base[version='>=3.0.6b.0,<4.0a0']", "numpy-base[version='1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.17.2.*|1.17.3.*|1.17.4.*|1.18.1.*|1.18.5.*|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.2',build='py36ha711998_0|py36h6575580_0|py38h68fea81_0|py37hcfb5961_0|py38hcfb5961_0|py36hcfb5961_0|py37hcfb5961_0|py38hcfb5961_0|py38h68fea81_0|py36h68fea81_0|py37h68fea81_0|py36hcfb5961_0|py37h68fea81_0|py36h68fea81_0|py38ha711998_0|py38h6575580_0|py37h6575580_0|py37ha711998_0']", 'six', 'sqlalchemy', "six[version='>=1.5']", "jpeg[version='>=9b,<10a']", "bob.io.base[version='>=3.0.10b.0,<4.0a0']", "mkl[version='>=2019.4,<2020.0a0']", "python[version='>=3.9,<3.10.0a0']"}
Uploading artifacts for failed job
Uploading artifacts...
Runtime platform
arch=amd64 os=darwin pid=32689 revision=ece86343 version=13.5.0
WARNING: coverage.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit status 1
failed
build_macosx_37 Build
    raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform osx-64: {'tzdata', "bob.db.base[version='>=3.0.6b.0,<4.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.7,<3.8.0a0']", 'six', 'python', 'ca-certificates', "python[version='>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']", "six[version='>=1.5']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "jpeg[version='>=9b,<10a']", 'setuptools', "bob.io.base[version='>=3.0.10b.0,<4.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", "libgfortran[version='>=3.0.1,<4.0.0.a0']", "blas[version='*|1.0',build='mkl|openblas']", "python[version='>=3.9,<3.10.0a0']", "python[version='>=3.5|>=3.7,<3.8.0a0|>=3.6,<3.7.0a0']", 'sqlalchemy', "bob.extension[version='>=5.0.2b.0,<6.0a0']", "bob.pad.base[version='>=2.3.2b.0,<3.0a0']"}
Uploading artifacts for failed job
Uploading artifacts...
Runtime platform
arch=amd64 os=darwin pid=32674 revision=ece86343 version=13.5.0
WARNING: coverage.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit status 1