Sphinx 3 autodoc no longer accepts autodoc_default_flags and autodoc_default_options should be used

5 jobs for master in 12 minutes and 42 seconds (queued for 7 seconds)
latest
Status Job ID Name Coverage
  Build
failed #216583
docker
build_linux_36

00:03:41

failed #216584
docker
build_linux_37

00:03:33

failed #216581
macosx
build_macosx_36

00:08:56

failed #216582
macosx
build_macosx_37

00:08:43

 
  Deploy
skipped #216585
docker
deploy_beta
 
Name Stage Failure
failed
build_macosx_37 Build
    raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform osx-64: {'setuptools', "mkl-service[version='>=2,<3.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "bob.pad.base[version='>=2.3.2b.0,<3.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']", 'tzdata', "bob.extension[version='>=5.0.2b.0,<6.0a0']", "python[version='>=3.9,<3.10.0a0']", 'six', "python[version='>=3.5|>=3.7,<3.8.0a0|>=3.6,<3.7.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", "bob.io.base[version='>=3.0.10b.0,<4.0a0']", "numpy-base[version='1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.17.2.*|1.17.3.*|1.17.4.*|1.18.1.*|1.18.5.*|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.2',build='py37ha711998_0|py38h6575580_0|py38ha711998_0|py36h68fea81_0|py38h68fea81_0|py37hcfb5961_0|py36hcfb5961_0|py38hcfb5961_0|py36hcfb5961_0|py37hcfb5961_0|py38h68fea81_0|py36h68fea81_0|py37h68fea81_0|py38hcfb5961_0|py37h68fea81_0|py37h6575580_0|py36h6575580_0|py36ha711998_0']", "bob.db.base[version='>=3.0.6b.0,<4.0a0']", 'ca-certificates', "python[version='>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "jpeg[version='>=9b,<10a']", 'sqlalchemy', "python[version='>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.7,<3.8.0a0']", 'python', "six[version='>=1.5']"}
Uploading artifacts for failed job
Uploading artifacts...
Runtime platform
arch=amd64 os=darwin pid=85340 revision=ece86343 version=13.5.0
WARNING: coverage.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit status 1
failed
build_macosx_36 Build
    raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform osx-64: {"bob.extension[version='>=5.0.2b.0,<6.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']", "bob.io.base[version='>=3.0.10b.0,<4.0a0']", "python[version='>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "numpy-base[version='1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.17.2.*|1.17.3.*|1.17.4.*|1.18.1.*|1.18.5.*|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.2',build='py37h6575580_0|py38h6575580_0|py36h68fea81_0|py38h68fea81_0|py37h68fea81_0|py36hcfb5961_0|py38hcfb5961_0|py38hcfb5961_0|py37h68fea81_0|py36h68fea81_0|py38h68fea81_0|py37hcfb5961_0|py36hcfb5961_0|py37hcfb5961_0|py38ha711998_0|py36h6575580_0|py36ha711998_0|py37ha711998_0']", "bob.pad.base[version='>=2.3.2b.0,<3.0a0']", "mkl[version='>=2019.4,<2020.0a0']", "python[version='>=3.5|>=3.7,<3.8.0a0|>=3.6,<3.7.0a0']", 'ca-certificates', "six[version='>=1.5']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "bob.db.base[version='>=3.0.6b.0,<4.0a0']", 'setuptools', "giflib[version='>=5.1.4,<5.2.0a0']", "python[version='>=3.9,<3.10.0a0']", 'tzdata', 'six', "python[version='>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.7,<3.8.0a0']", 'sqlalchemy', "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", 'python'}
Uploading artifacts for failed job
Uploading artifacts...
Runtime platform
arch=amd64 os=darwin pid=85276 revision=ece86343 version=13.5.0
WARNING: coverage.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit status 1
failed
build_linux_36 Build
  File "/scratch/builds/bob/bob.db.uvad/miniconda/lib/python3.7/site-packages/conda_build/environ.py", line 804, in get_install_actions
raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform linux-64: {"bob.extension[version='>=5.0.2b.0,<6.0a0']", 'six', 'ca-certificates', "bob.pad.base[version='>=2.3.2b.0,<3.0a0']", 'tzdata', 'setuptools', "bob.io.base[version='>=3.0.10b.0,<4.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.8,<3.9.0a0|>=3.9,<3.10.0a0|>=3.7,<3.8.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']", "python[version='>=3.9,<3.10.0a0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", "bob.db.base[version='>=3.0.6b.0,<4.0a0']", "python[version='>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", "giflib[version='>=5.1.4,<5.2.0a0']", "numpy-base[version='1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.17.2.*|1.17.3.*|1.17.4.*|1.18.1.*|1.18.5.*|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.2',build='py37h2f8d375_0|py37hde5b4d6_0|py36hde5b4d6_0|py38hde5b4d6_0|py38hfa32c7d_0|py37h75fe3a5_0|py37hfa32c7d_0|py38h75fe3a5_0|py37h75fe3a5_0|py36h75fe3a5_0|py38hfa32c7d_0|py36hfa32c7d_0|py36h75fe3a5_0|py36hfa32c7d_0|py38h75fe3a5_0|py37hfa32c7d_0|py38h2f8d375_0|py36h2f8d375_0']", 'python', "blas[version='*|1.0',build='openblas|mkl']", "six[version='>=1.5']", 'sqlalchemy', "python[version='>=3.5|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", '_libgcc_mutex=[build=main]'}
Uploading artifacts for failed job
Uploading artifacts...
WARNING: coverage.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
build_linux_37 Build
  File "/scratch/builds/bob/bob.db.uvad/miniconda/lib/python3.7/site-packages/conda_build/environ.py", line 804, in get_install_actions
raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform linux-64: {'sqlalchemy', "bob.io.base[version='>=3.0.10b.0,<4.0a0']", "bob.extension[version='>=5.0.2b.0,<6.0a0']", "python[version='>=3.9,<3.10.0a0']", "numpy-base[version='1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.16.6|1.17.2.*|1.17.3.*|1.17.4.*|1.18.1.*|1.18.5.*|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.1|1.19.2',build='py37h2f8d375_0|py37hde5b4d6_0|py37hfa32c7d_0|py38hfa32c7d_0|py36h75fe3a5_0|py37hfa32c7d_0|py37h75fe3a5_0|py36h75fe3a5_0|py38hfa32c7d_0|py36hfa32c7d_0|py38h75fe3a5_0|py37h75fe3a5_0|py36hfa32c7d_0|py38h75fe3a5_0|py38hde5b4d6_0|py38h2f8d375_0|py36hde5b4d6_0|py36h2f8d375_0']", "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0']", "six[version='>=1.5']", "libopenblas[version='>=0.3.3,<1.0a0']", 'ca-certificates', "bob.pad.base[version='>=2.3.2b.0,<3.0a0']", "python[version='>=3.5|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", "giflib[version='>=5.1.4,<5.2.0a0']", "python[version='>=3.8,<3.9.0a0|>=3.9,<3.10.0a0']", 'tzdata', 'setuptools', 'six', "python[version='>=3.6,<3.7.0a0|>=3.7,<3.8.0a0']", '_libgcc_mutex=[build=main]', "bob.db.base[version='>=3.0.6b.0,<4.0a0']"}
Uploading artifacts for failed job
Uploading artifacts...
WARNING: coverage.xml: no matching files
ERROR: No files to upload
Cleaning up file based variables
ERROR: Job failed: exit code 1