[conda_build_config] Use boost 1.71 (with py38 bindings)

2 jobs for python38 in 39 minutes and 56 seconds (queued for 2 seconds)
Status Job ID Name Coverage
  Build
failed #206700
docker
build_linux

00:39:53

failed #206701
macosx
build_macosx

00:01:42

 
Name Stage Failure
failed
build_linux Build
Package numpy conflicts for:
numpy=1.15.4
py-boost=1.71.0 -> numpy[version='>=1.11.3,<2.0a0|>=1.14.6,<2.0a0']

Package libgcc-ng conflicts for:
python=3.8 -> libgcc-ng[version='>=7.3.0']
python=3.8 -> zlib[version='>=1.2.11,<1.3.0a0'] -> libgcc-ng[version='>=7.2.0']
Note that strict channel priority may have removed packages required for satisfiability.
ERROR: Job failed: exit code 1
failed
build_macosx Build
sqlite=3.29.0 -> zlib[version='>=1.2.11,<1.3.0a0']
py-boost=1.71.0 -> libboost[version='>=1.71.0,<1.71.1.0a0',build=h15b55ba_0] -> zlib[version='>=1.2.11,<1.3.0a0']
libpng=1.6.35 -> zlib[version='>=1.2.11,<1.3.0a0']
numpy=1.15.4 -> python[version='>=3.6,<3.7.0a0'] -> zlib[version='>=1.2.11,<1.3.0a0']

Package numpy conflicts for:
py-boost=1.71.0 -> numpy[version='>=1.14.6,<2.0a0']
numpy=1.15.4
ERROR: Job failed: exit status 1