[ci] Do not install twine on deployment (only docs anyways)

5 jobs for master in 1 minute and 36 seconds (queued for 8 seconds)
Status Job ID Name Coverage
  Build
passed #247459
docker
build

00:00:41

 
  Test
passed #247462
docker
test_py310

00:00:35

25.0%
passed #247460
docker
test_py38

00:00:35

25.0%
passed #247461
docker
test_py39

00:00:33

25.0%
 
  Deploy
failed #247463
docker
deploy_beta

00:00:19

 
Name Stage Failure
failed
deploy_beta Deploy
  Downloading GitPython-3.1.24-py3-none-any.whl (180 kB)
Collecting tabulate
Downloading tabulate-0.8.9-py3-none-any.whl (25 kB)
ERROR: Could not find a version that satisfies the requirement black>=19 (from bob-devtools) (from versions: 18.3a0, 18.3a1, 18.3a2, 18.3a3, 18.3a4, 18.4a0, 18.4a1, 18.4a2, 18.4a3, 18.4a4, 18.5b0, 18.5b1, 18.6b0, 18.6b1, 18.6b2, 18.6b3, 18.6b4, 18.9b0, 19.3b0, 19.10b0, 20.8b0, 20.8b1, 21.4b0, 21.4b1, 21.4b2, 21.5b0, 21.5b1, 21.5b2, 21.6b0, 21.7b0, 21.8b0, 21.9b0)
ERROR: No matching distribution found for black>=19
WARNING: You are using pip version 21.2.4; however, version 21.3 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Cleaning up project directory and file based variables
ERROR: Job failed: exit code 1