Migrate to conda based CI

5 jobs for condapackage in 5 minutes and 12 seconds (queued for 31 minutes and 53 seconds)
Status Job ID Name Coverage
  Build
failed #115712
docker
build_linux_27

00:05:00

failed #115713
docker
build_linux_36

00:05:02

failed #115714
macosx
build_macosx_27

00:02:59

failed #115715
macosx
build_macosx_36

00:02:59

 
  Deploy
skipped #115716
deployer
deploy_beta
 
Name Stage Failure
failed
build_macosx_36 Build There is an unknown failure, please try again
  File "/Users/buildbot/work/gitlab-ci/f6f95b82/1/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/render.py", line 613, in render_recipe
m = MetaData(recipe_dir, config=config)
File "/Users/buildbot/work/gitlab-ci/f6f95b82/1/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/metadata.py", line 738, in __init__
self.meta_path = find_recipe(path)
File "/Users/buildbot/work/gitlab-ci/f6f95b82/1/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/utils.py", line 793, in find_recipe
raise IOError("More than one meta.yaml files found in %s" % path)
OSError: More than one meta.yaml files found in /Users/buildbot/work/gitlab-ci/f6f95b82/1/bob/bob.learn.activation
(19:39:50.872)
Error: Command Failed "/Users/buildbot/work/gitlab-ci/f6f95b82/1/bob/bob.bio.base/miniconda/bin/conda build --no-anaconda-upload --variant-config-files _ci/conda_build_config.yaml --python=3.6 conda"
ERROR: Job failed: exit status 1
failed
build_macosx_27 Build There is an unknown failure, please try again
  File "/Users/buildbot/work/gitlab-ci/f6f95b82/0/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/render.py", line 613, in render_recipe
m = MetaData(recipe_dir, config=config)
File "/Users/buildbot/work/gitlab-ci/f6f95b82/0/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/metadata.py", line 738, in __init__
self.meta_path = find_recipe(path)
File "/Users/buildbot/work/gitlab-ci/f6f95b82/0/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/utils.py", line 793, in find_recipe
raise IOError("More than one meta.yaml files found in %s" % path)
OSError: More than one meta.yaml files found in /Users/buildbot/work/gitlab-ci/f6f95b82/0/bob/bob.math
(19:39:34.925)
Error: Command Failed "/Users/buildbot/work/gitlab-ci/f6f95b82/0/bob/bob.bio.base/miniconda/bin/conda build --no-anaconda-upload --variant-config-files _ci/conda_build_config.yaml --python=2.7 conda"
ERROR: Job failed: exit status 1
failed
build_linux_36 Build There is an unknown failure, please try again
  File "/local/builds/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/render.py", line 282, in _read_upstream_pin_files
permit_unsatisfiable_variants=permit_unsatisfiable_variants)
File "/local/builds/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/render.py", line 117, in get_env_dependencies
channel_urls=tuple(m.config.channel_urls))
File "/local/builds/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/environ.py", line 708, in get_install_actions
raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform linux-64: {'bob.learn.em', 'bob.core', 'bob.db.base', 'bob.learn.activation', 'bob.measure', 'bob.sp', 'bob.io.base', 'bob.math', 'bob.learn.linear'}
(18:32:38.708)
Error: Command Failed "/local/builds/bob/bob.bio.base/miniconda/bin/conda build --no-anaconda-upload --variant-config-files _ci/conda_build_config.yaml --python=3.6 conda"
ERROR: Job failed: exit code 1
failed
build_linux_27 Build There is an unknown failure, please try again
  File "/local/builds/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/render.py", line 282, in _read_upstream_pin_files
permit_unsatisfiable_variants=permit_unsatisfiable_variants)
File "/local/builds/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/render.py", line 117, in get_env_dependencies
channel_urls=tuple(m.config.channel_urls))
File "/local/builds/bob/bob.bio.base/miniconda/lib/python3.6/site-packages/conda_build/environ.py", line 708, in get_install_actions
raise DependencyNeedsBuildingError(exc, subdir=subdir)
conda_build.exceptions.DependencyNeedsBuildingError: Unsatisfiable dependencies for platform linux-64: {'bob.math', 'bob.measure', 'bob.sp', 'bob.core', 'bob.learn.em', 'bob.learn.linear', 'bob.db.base', 'bob.learn.activation', 'bob.io.base'}
(18:32:26.789)
Error: Command Failed "/local/builds/bob/bob.bio.base/miniconda/bin/conda build --no-anaconda-upload --variant-config-files _ci/conda_build_config.yaml --python=2.7 conda"
ERROR: Job failed: exit code 1