Commit e0d32be0 authored by Manuel Günther's avatar Manuel Günther

Loading our own Library.

parent 132c52b1
# import Libraries of other lib packages
import bob.core
import bob.sp
# import our own Library
import bob.extension
bob.extension.load_bob_library('bob.ap', __file__)
from ._library import * from ._library import *
from . import version from . import version
from .version import module as __version__ from .version import module as __version__
......
...@@ -17,8 +17,6 @@ develop = src/bob.extension ...@@ -17,8 +17,6 @@ develop = src/bob.extension
; options for bob.buildout extension ; options for bob.buildout extension
debug = true debug = true
verbose = true verbose = true
prefixes = /idiap/group/torch5spro/nightlies/last/bob/linux-x86_64-release
/Users/andre/work/bob/b/dbg/
[sources] [sources]
bob.extension = git https://github.com/bioidiap/bob.extension bob.extension = git https://github.com/bioidiap/bob.extension
......
...@@ -3,8 +3,10 @@ ...@@ -3,8 +3,10 @@
# Andre Anjos <andre.anjos@idiap.ch> # Andre Anjos <andre.anjos@idiap.ch>
# Thu 30 Jan 08:45:49 2014 CET # Thu 30 Jan 08:45:49 2014 CET
bob_packages = ['bob.core', 'bob.sp']
from setuptools import setup, find_packages, dist from setuptools import setup, find_packages, dist
dist.Distribution(dict(setup_requires=['bob.blitz', 'bob.core', 'bob.sp'])) dist.Distribution(dict(setup_requires=['bob.blitz'] + bob_packages))
from bob.blitz.extension import Extension, Library, build_ext from bob.blitz.extension import Extension, Library, build_ext
version = '2.0.0a0' version = '2.0.0a0'
...@@ -43,7 +45,7 @@ setup( ...@@ -43,7 +45,7 @@ setup(
"bob/ap/version.cpp", "bob/ap/version.cpp",
], ],
version = version, version = version,
bob_packages = ['bob.core', 'bob.sp'] bob_packages = bob_packages,
), ),
Library("bob.ap.bob_ap", Library("bob.ap.bob_ap",
...@@ -54,7 +56,7 @@ setup( ...@@ -54,7 +56,7 @@ setup(
"bob/ap/cpp/Ceps.cpp", "bob/ap/cpp/Ceps.cpp",
], ],
version = version, version = version,
bob_packages = ['bob.core', 'bob.sp'] bob_packages = bob_packages,
), ),
Extension("bob.ap._library", Extension("bob.ap._library",
...@@ -66,7 +68,7 @@ setup( ...@@ -66,7 +68,7 @@ setup(
"bob/ap/main.cpp", "bob/ap/main.cpp",
], ],
version = version, version = version,
bob_packages = ['bob.core', 'bob.sp'] bob_packages = bob_packages,
), ),
], ],
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment