[dev.yml] Fix all the beat dependencies to match the versions used by buildout

Since beat.core is fixed at 1.8.0, the others must also
be pinned to their corresponding versions.

See release.cfg
1 job for fix_test_dependencies in 15 minutes and 38 seconds (queued for 9 seconds)
Status Job ID Name Coverage
  Build
canceled #176079
docker-build
build_linux_36

00:15:38