dev.yml 1.02 KB
Newer Older
1 2
name: beat-web
channels:
3
  - http://www.idiap.ch/software/beat/conda
4 5
  - defaults
dependencies:
6 7
  - pip

8
  # packages you may pin are here
9
  - python=3.7
10 11
  - bob-devel=2020.01.09
  - beat-devel=2020.01.09
12

13
  # beat dependencies matching release.cfg
14
  - beat.core=1.13.3
15
  - beat.backend.python=1.7.12
16
  - beat.cmdline=1.10.1
17 18

  # requirements.txt, they are indirectly pinned through the above
19 20 21 22 23
  - docopt
  - docutils
  - jinja2
  - matplotlib
  - psutil
24
  - psycopg2
25 26
  - pytz
  - simplejson
27 28

  # these are required for local development, they are not runtime
29 30 31 32 33 34
  - bob.extension
  - nose
  - coverage
  - sphinx
  - sphinx_rtd_theme
  - bob.buildout
35
  - mr.developer
36
  - sphinxcontrib-programoutput
37
  - sphinxcontrib-httpdomain
38 39

  # add here, packages which are **not** available on above channels
40
  - pip:
41 42 43 44 45 46 47
    - django>=3.0,<4.0
    - django-activity-stream
    - django-guardian
    - django-jsonfield
    - django-jsonfield-compat
    - django-post_office
    - drf-yasg
48
    - djangorestframework<3.12
49 50
    - sphinxcontrib-openapi
    - jsonfield