Commit 836031b6 authored by André Anjos's avatar André Anjos 💬 Committed by Samuel GAIST
Browse files

[ci] Update docker images versions and pull them

parent fbdae09e
......@@ -22,6 +22,7 @@ stages:
- chmod 755 _ci/install.sh
- ./_ci/install.sh _ci master #installs ci support scripts
- ./_ci/before_build.sh
- ./scripts/before_test.sh #pulls required docker images
script:
- ./_ci/build.sh
after_script:
......
......@@ -26,7 +26,7 @@ if [ "$1" == "build" ]; then
# V2 builds
echo "Building v2 algorithm"
DOCKER_IMAGE="docker.idiap.ch/beat/beat.env.client:2.0.0"
DOCKER_IMAGE="docker.idiap.ch/beat/beat.env.client:2.0.0r1"
types=('legacy' 'autonomous' 'sequential' 'analyzer')
# types=('autonomous')
for type in "${types[@]}"; do
......
#! /bin/bash
IMAGES=(
docker.idiap.ch/beat/beat.env.system.python:1.3.0r1
docker.idiap.ch/beat/beat.env.db.examples:1.4.0r1
docker.idiap.ch/beat/beat.env.system.python:1.3.0r3
docker.idiap.ch/beat/beat.env.db.examples:1.4.0r3
docker.idiap.ch/beat/beat.env.cxx:2.0.0r1
docker.idiap.ch/beat/beat.env.client:2.0.0r1
)
......@@ -33,7 +33,7 @@ if [ ${#MISSING_IMAGES[@]} -gt 0 ]; then
MUST_PULL=0
if [ -z "$CI_SERVER" ]; then
read -p "Do you want to install them now? (yes/no) " -n 1 -r
read -p "Do you want to install them now? (y/n) " -n 1 -r
echo
if [[ $REPLY =~ ^[Yy]$ ]]; then
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment